Page 1 of 1

Encountering error: rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

Posted: Tue Mar 24, 2020 3:32 pm
by declanshanaghy
I compiled an ESPHome binary and uploaded to this device using esptool.py:
https://www.banggood.com/LILYGO-TTGO-T- ... rehouse=CN

The command I used was:

Code: Select all

esptool.py -p /dev/cu.SLAB_USBtoUART write_flash -z 0x1000 ttgocam.bin
It uploaded without error

Code: Select all

esptool.py v2.8
Serial port /dev/cu.SLAB_USBtoUART
Connecting......
Detecting chip type... ESP32
Chip is ESP32D0WDQ5 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
MAC: 30:ae:a4:dc:c9:c0
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Compressed 1092848 bytes to 592236...
Wrote 1092848 bytes (592236 compressed) at 0x00001000 in 52.1 seconds (effective 167.8 kbit/s)...
Hash of data verified.

Leaving...
Hard resetting via RTS pin...
It didn't start up and after quite a while trying to figure out what might have gone wrong I realized I probably shouldn't have loaded the binary at 0x1000 so i repeated the procedure using 0x0000. Still it didn't boot up.

Upon examining the serial output I see this...

Code: Select all

rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3f400020,len:277444
ets Jun  8 2016 00:22:57

REPEATS...
When searching for this error, most solutions suggest erasing the flash and re-flashing. I did that multiple times, to no avail.
Any suggestions on how to proceed?

Re: Encountering error: rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

Posted: Tue Mar 24, 2020 7:08 pm
by warren
Well, it looks like you need to perform some debugging to narrow down the cause of the problem. The source code seems to be available here https://github.com/Xinyuan-LilyGO/esp32 ... series.ino, so download it and load it up into your Arduino IDE.

Start adding Serial.print* statements starting with the setup() routine. Basic troubleshooting-- narrow down which portion that the code falls apart in. Does it even get started, is a good place to begin.

Code: Select all

void setup()
{

    Serial.begin(115200);
    Serial.setDebugOutput(true);
    Serial.println();
    Serial.println("Program begun!");
Keep adding prints where you need to confirm it has run (or not). Not all published code is guaranteed to work or handle all configurations. Good luck.

Re: Encountering error: rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

Posted: Tue Mar 24, 2020 10:20 pm
by declanshanaghy
Hey, nice find. I hadn't thought to look for the original source.

The bin file i uploaded is a binary I compiled with ESPHome.
Will give your suggestion a try and see how it goes though

Come to think of it, i should try reverting to the firmware backup I made and see if that works now.

Re: Encountering error: rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

Posted: Wed Mar 25, 2020 5:32 am
by WiFive
You need bootloader, partition table, and firmware

Re: Encountering error: rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

Posted: Wed Mar 25, 2020 2:11 pm
by declanshanaghy
I reverted to the original firmware using NodeMCUPyFlasher and it worked just fine.
Then just for shits 'n' giggles I decided to try out ESPHomeFlasher to upload my ESPHome binary and it worked!

I had originally uploaded with Tasmotizer and esptool.py to no avail. Tasmotizer has worked for me in the past to upload ESPHome binaries to ESP8266 devices. Something different with the ESP32, I suspect.

Seems like ESPHomeFlasher provides it's own bootloader and partition table maybe?

I realize this isn't the exact right forum, but if anyone can shed some light on the subtle differences for me it would be really helpful.

Thanks for the help.
Dek