OTA failure with HTTP_UPDATE_FAILD Error (0)

avnergid
Posts: 3
Joined: Fri Mar 27, 2020 7:36 pm

OTA failure with HTTP_UPDATE_FAILD Error (0)

Postby avnergid » Thu May 14, 2020 3:31 pm

With code that worked many times before, I am suddenly starting to get consistent update errors on *multiple* devices.
Any ideas why ?
Replaced the bin with a fresh one in case of corruption, uploaded manually to ensure the compile is good.


18:25:53.324 -> x-ESP32-STA-MAC: 24:6F:28:9E:49:5C
18:25:53.324 -> x-ESP32-AP-MAC: 24:6F:28:9E:49:5D
18:25:53.324 -> x-ESP32-free-space: 1310720
18:25:53.324 -> x-ESP32-sketch-size: 987232
18:25:53.324 -> x-ESP32-sketch-md5: d8ea86480818d4e3b3b567b36ff490d2
18:25:53.324 -> x-ESP32-sketch-sha256: CABD6467749DD9221E6967DAE460946CD9F5DAC5F58AC8D63762449B25D19ECC
18:25:53.324 -> x-ESP32-chip-size: 4194304
18:25:53.324 -> x-ESP32-sdk-version: v3.2.3-14-gd3e562907
18:25:53.324 -> x-ESP32-mode: sketch
18:25:53.324 ->
18:25:53.324 ->
18:25:53.583 -> HTTP_UPDATE_FAILD Error (0): HTTP_UPDATE_NO_UPDATES.

Cum1mings
Posts: 1
Joined: Fri May 15, 2020 6:10 am

Re: OTA failure with HTTP_UPDATE_FAILD Error (0)

Postby Cum1mings » Fri May 15, 2020 6:48 am

If OTA update fails, first step is to check for error messages that may be shown in upload window of Arduino IDE mcdvoice.

avnergid
Posts: 3
Joined: Fri Mar 27, 2020 7:36 pm

Re: OTA failure with HTTP_UPDATE_FAILD Error (0)

Postby avnergid » Fri May 15, 2020 5:56 pm

The plot thickens.
I'm pulling the bin file from raw.githubusercontent.com.
This worked perfectly well few months.
Suddently, earlier this week it stopped without code changes on my end.

Getting HTTP_UPDATE_FAILD Error (-1): HTTP error: connection refusedHTTP_UPDATE_NO_UPDATES.

Anonymous browser will download the file as before.

Trying to "debug" it a bit, looked into HTTPUpdate.cpp.
the first function where things don't work as they should is

bool HTTPUpdate::runUpdate(Stream &in, uint32_t size, String md5, int command)

the very first check (!begin) is already failing and returning error.

if (!Update.begin(size, command, _ledPin, _ledOn))


Any Ideas ?

andrewpiana
Posts: 1
Joined: Fri Jun 26, 2020 2:09 pm

Re: OTA failure with HTTP_UPDATE_FAILD Error (0)

Postby andrewpiana » Fri Jun 26, 2020 2:13 pm

Cum1mings wrote:
Fri May 15, 2020 6:48 am
If OTA update fails, first step is to check for error messages that may be shown in upload window of Arduino IDE mcdvoice.
yeah after resolving the error it will begin

Who is online

Users browsing this forum: Baidu [Spider] and 20 guests