[solved] build problem

park_lemon
Posts: 10
Joined: Mon Sep 07, 2020 10:07 am

[solved] build problem

Postby park_lemon » Tue Sep 08, 2020 4:30 am

Hi all,

I need help,

after build, i got this message:

12:25:25 **** Build of configuration Default for project HelloWorld ****
python C:/msys32/home/vinodh/esp/esp-idf/tools/windows/eclipse_make.py flash
Traceback (most recent call last):
File "C:/msys32/home/vinodh/esp/esp-idf/tools/windows/eclipse_make.py", line 43, in <module>
main()
File "C:/msys32/home/vinodh/esp/esp-idf/tools/windows/eclipse_make.py", line 34, in main
print("Running make in '%s'" % check_path(os.getcwd()))
File "C:/msys32/home/vinodh/esp/esp-idf/tools/windows/eclipse_make.py", line 28, in check_path
winpath = winpath.replace("\\", "/") # make consistent with forward-slashes used elsewhere
TypeError: a bytes-like object is required, not 'str'
"python C:/msys32/home/vinodh/esp/esp-idf/tools/windows/eclipse_make.py flash" terminated with exit code 1. Build might be incomplete.

12:25:26 Build Finished. 0 errors, 0 warnings. (took 576ms)

what doest it meant, i susseccful build or not?

User avatar
ESP_Roland
Posts: 96
Joined: Tue Oct 09, 2018 10:28 am

Re: build problem

Postby ESP_Roland » Tue Sep 08, 2020 9:09 am

Hi park_lemon,

your build has probably been completed successfully but flashing has failed because of a Python compatibility issue.

Could you please try to modify line no. 23 of tools/windows/eclipse_make.py by changing

Code: Select all

winpath = subprocess.check_output(["cygpath", "-w", path]).strip()
to

Code: Select all

winpath = subprocess.check_output(["cygpath", "-w", path]).decode().strip()
i.e. adding ".decode()". Please let me know if this helps or not.

park_lemon
Posts: 10
Joined: Mon Sep 07, 2020 10:07 am

Re: build problem

Postby park_lemon » Wed Sep 09, 2020 9:19 am

Hi,

Thank you very much for your reply and help.
May god bless you.

your help really good...it helps me a lot.

For those who face same problems like me.

You may refer to these following link:
1. https://www.instructables.com/id/ESP32- ... lipse-IDE/
2. https://github.com/espressif/idf-eclips ... ingStarted

Just for sharing:
I takes almost 3 days just for installation and setting eclipse. Hope ESP32 can make their own IDE that are user friendly, easy to install, build, compile and debug. No need much setting. Make it simple for rapid development.

User avatar
ESP_Roland
Posts: 96
Joined: Tue Oct 09, 2018 10:28 am

Re: build problem

Postby ESP_Roland » Wed Sep 09, 2020 10:56 am

Thank you park_lemon for your feedback. I will include the fix in the following releases.

We are sorry that the setup of Eclipse took you so long. If you think that some parts of the description was misleading or incomplete then please consider raising an issue about it at https://github.com/espressif/idf-eclipse-plugin/issues so we could improve it.

User avatar
ESP_Roland
Posts: 96
Joined: Tue Oct 09, 2018 10:28 am

Re: build problem

Postby ESP_Roland » Thu Sep 10, 2020 7:43 am

For future reference, commit 3c7954ea497649a4cd6520842151deb632bc4723 will fix this issue and will available in the master branch on Github with the next update. The fix will be backported to release branches.

Who is online

Users browsing this forum: No registered users and 30 guests