idf.py monitor stopped working -TinyPico-

ich_hci
Posts: 2
Joined: Tue Sep 08, 2020 10:45 pm

idf.py monitor stopped working -TinyPico-

Postby ich_hci » Tue Sep 08, 2020 10:59 pm

Hi!

I am having an issue. Suddenly, the monitor is not working. It does the following:

idf.py -p /dev/ttyUSB9 monitor
Executing action: monitor
Running idf_monitor in directory /home/user/esp/esp-idf/examples/i2c_test
Executing "/home/user/.espressif/python_env/idf4.1_py2.7_env/bin/python /home/user/esp/esp-idf/tools/idf_monitor.py -p /dev/ttyUSB9 -b 115200 --toolchain-prefix xtensa-esp32-elf- /home/user/esp/esp-idf/examples/i2c_test/build/i2c-test.elf -m '/home/user/.espressif/python_env/idf4.1_py2.7_env/bin/python' '/home/user/esp/esp-idf/tools/idf.py' '-p' '/dev/ttyUSB9'"...
--- idf_monitor on /dev/ttyUSB9 115200 ---
--- Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H ---

I did not upgrade anything. I tried to reboot the laptop but it remains the same behaviour. I have tried with different firmwares (some of them examples which worked without problem previously) and it still having the same behaviour. I can flash new firmwares without problem.

Additional information: Now sometimes when flashing, it throws the following error:

Executing action: flash
Running esptool.py in directory /home/user/esp/esp-idf/examples/provisioning/ble_prov/build
Executing "/home/user/.espressif/python_env/idf4.1_py2.7_env/bin/python /home/user/esp/esp-idf/components/esptool_py/esptool/esptool.py -p /dev/ttyUSB9 -b 460800 --before default_reset --after hard_reset --chip esp32 write_flash @flash_project_args"...
esptool.py -p /dev/ttyUSB9 -b 460800 --before default_reset --after hard_reset --chip esp32 write_flash --flash_mode dio --flash_freq 40m --flash_size 2MB 0x8000 partition_table/partition-table.bin 0x1000 bootloader/bootloader.bin 0x10000 ble_prov.bin
esptool.py v2.9-dev
Serial port /dev/ttyUSB9
Connecting........_____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header
esptool.py failed with exit code 2

Any idea what could be the problem and how it could be solverd?

Thank you very much in advance!

User avatar
ESP_Roland
Posts: 96
Joined: Tue Oct 09, 2018 10:28 am

Re: idf.py monitor stopped working -TinyPico-

Postby ESP_Roland » Wed Sep 09, 2020 10:45 am

Hi ich_hci,

maybe your port has changed. Try to disconnect the device, list the available ports, reconnect and compare the list of available ports.

ich_hci
Posts: 2
Joined: Tue Sep 08, 2020 10:45 pm

Re: idf.py monitor stopped working -TinyPico-

Postby ich_hci » Wed Sep 09, 2020 2:17 pm

Hi!

Thanks for your response. I have been talking for a while with Unexpected Maker about this issue.

When using screen command in Linux and I reset (shortcut RESET+GND), it works, but form idf.py monitor it doesn't, and if I try to reset doing that, it says something like "Waiting for Upload".

I will keep trying to totally fix it, and in case I found a solution I will write here the answer.

Thanks!

Best regards

Who is online

Users browsing this forum: Bing [Bot] and 45 guests