OpenOCD and hardware debugger support

a2retro
Posts: 56
Joined: Tue Dec 01, 2015 3:09 am

Re: OpenOCD and hardware debugger support

Postby a2retro » Tue Sep 27, 2016 3:06 am

So I am working on config/communication issues now. I am trying to use my Particle Programmer Shield, only ftdi 2232H device I have on hand using the config from the Particle github repo.

adapter speed: 200 kHz
Error: libusb_open() failed with LIBUSB_ERROR_NOT_SUPPORTED
Error: libusb_open() failed with LIBUSB_ERROR_NOT_FOUND
Error: no device found
Error: unable to open ftdi device with vid 0403, pid 6010, description '*', serial '*' at bus location '*'

Just to confirm there are two esp32.cfg files. The one in target that I should not have to modify and the one copied in to the src dir from docs which I do, correct?

a2retro
Posts: 56
Joined: Tue Dec 01, 2015 3:09 am

Re: OpenOCD and hardware debugger support

Postby a2retro » Tue Sep 27, 2016 4:03 am

So after downloading zadig and setting Port A to libusbK - and finally figuring out I needed a reboot

I have

adapter speed: 200 kHz
Error: libusb_open() failed with LIBUSB_ERROR_NOT_SUPPORTED
Info : clock speed 200 kHz
Info : JTAG tap: esp32.cpu0 tap/device found: 0x120034e5 (mfg: 0x272 (Tensilica), part: 0x2003, ver: 0x1)
Info : JTAG tap: esp32.cpu1 tap/device found: 0x120034e5 (mfg: 0x272 (Tensilica), part: 0x2003, ver: 0x1)
Info : esp32.cpu0: Debug controller was reset (pwrstat=0x5F, after clear 0x0F).
Info : esp32.cpu0: Core was reset (pwrstat=0x5F, after clear 0x0F).

So I think that's okay - not sure why there is still an error?

ESP_Sprite
Posts: 2908
Joined: Thu Nov 26, 2015 4:08 am

Re: OpenOCD and hardware debugger support

Postby ESP_Sprite » Tue Sep 27, 2016 9:32 am

No clue why the error is there - maybe openocd is trying to also attach itself to one of your other USB devices and failing before finally finding the correct one. The ESP32 is found and the reset message is normal, though, so you should be able to start debugging.

ChrisHolza
Posts: 7
Joined: Mon Jan 09, 2017 1:32 pm
Location: Germany

Re: OpenOCD and hardware debugger support

Postby ChrisHolza » Mon Jan 09, 2017 1:41 pm

After running pacman -Syu, had trouble when making or gitting, like
': not a valid identifier.9: export: `dashless
': not a valid identifier.9: export: `dashless
': not a valid identifier.9: export: `dashless

Looks like there are issues with git 2.10 which is inistalled by pacman -Syu, so I recommend upgrading everything except git.
To do so, edit pacman's ignore list in [..]/msys32/etc/pacman.conf and change one line from

Code: Select all

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
to

Code: Select all

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = git
This helped for me.
Remember to do this before running pacman -Syu, and to change it back one day if you want or have to upgrade git.

Who is online

Users browsing this forum: MSN [Bot] and 32 guests