Tools setup - python packages dependency problem?

User avatar
Posts: 8
Joined: Mon Jun 17, 2019 11:20 pm

Tools setup - python packages dependency problem?

Postby TinkerBearNZ » Mon Jan 04, 2021 4:48 am

Hi there!

I'm trying to update some sources from the v3.3.4 esp-idf to v4.2.0 - need to get the v4.2 tools set up first.

Following the Getting Started guide: ... index.html

When I run, it fails during the installation of the python packages, specifically gdbgui This version of gdbgui apparently requires Flask-SocketIO >= 2.9, which needs bidict >= 0.21.0... when bidict 0.18.3 was the last to support python 2.7.

Any ideas how to resolve this?

I've seen some other posts referencing python 3.7, but I thought the build system required python 2.7? Switching to a currently-supported version of Python would be preferable, but I mainly just need to get the code building.

Here's the long dreary output:

Code: Select all

esp-idf % pip install gdbgui==
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at pip 21.0 will remove support for this functionality.
Processing /Users/brsmith/Library/Caches/pip/wheels/bd/cb/ff/5fe8d2ecf6d3252de026aa42311e72872d57fbff3889e348d1/gdbgui-
Collecting Flask<1.0,>=0.12.2
  Using cached Flask-0.12.5-py2.py3-none-any.whl (81 kB)
Collecting pygdbmi<1.0,>=
  Downloading pygdbmi- (18 kB)
Collecting Pygments<3.0,>=2.2.0
  Using cached Pygments-2.5.2-py2.py3-none-any.whl (896 kB)
Processing /Users/brsmith/Library/Caches/pip/wheels/8a/bb/96/b34a562c66c1314b537d6b49da050a1d133ae1f9af36d229c5/Flask_Compress-1.8.0-py2-none-any.whl
Collecting gevent<2.0,>=1.2.2
  Using cached gevent-1.5.0-cp27-cp27m-macosx_10_9_x86_64.whl (1.7 MB)
Collecting Flask-SocketIO<3.0,>=2.9
  Using cached Flask_SocketIO-2.9.6-py2.py3-none-any.whl (16 kB)
Requirement already satisfied: click>=2.0 in /Users/brsmith/esp/tools/python_env/idf4.2_py2.7_env/lib/python2.7/site-packages (from Flask<1.0,>=0.12.2->gdbgui== (7.1.2)
Collecting itsdangerous>=0.21
  Using cached itsdangerous-1.1.0-py2.py3-none-any.whl (16 kB)
Collecting Werkzeug<1.0,>=0.7
  Using cached Werkzeug-0.16.1-py2.py3-none-any.whl (327 kB)
Collecting Jinja2>=2.4
  Using cached Jinja2-2.11.2-py2.py3-none-any.whl (125 kB)
Collecting brotli
  Using cached Brotli-1.0.9-cp27-cp27m-macosx_10_9_x86_64.whl (417 kB)
Collecting greenlet>=0.4.14; platform_python_implementation == "CPython"
  Using cached greenlet-0.4.17.tar.gz (61 kB)
Collecting python-socketio>=1.6.1
  Using cached python_socketio-5.0.4-py2.py3-none-any.whl (52 kB)
Collecting MarkupSafe>=0.23
  Using cached MarkupSafe-1.1.1-cp27-cp27m-macosx_10_6_intel.whl (17 kB)
ERROR: Could not find a version that satisfies the requirement bidict>=0.21.0 (from python-socketio>=1.6.1->Flask-SocketIO<3.0,>=2.9->gdbgui== (from versions: 0.1.5, 0.2.1, 0.3.0, 0.3.1, 0.9.0rc0, 0.9.0.post1, 0.10.0, 0.10.0.post1, 0.11.0, 0.12.0.post1, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.14.2, 0.15.0.dev0, 0.15.0.dev1, 0.15.0rc1, 0.15.0, 0.16.0, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.4, 0.17.5, 0.18.0, 0.18.1, 0.18.2, 0.18.3, 0.18.4)
ERROR: No matching distribution found for bidict>=0.21.0 (from python-socketio>=1.6.1->Flask-SocketIO<3.0,>=2.9->gdbgui==
Thanks for any help you can offer!

Posts: 32
Joined: Fri May 29, 2020 2:52 pm

Re: Tools setup - python packages dependency problem?

Postby dastoned » Mon Jan 04, 2021 10:32 pm

ESP IDF 4.2 needs Python 3, not 2: ... setup.html

Go ahead and upgrade your Python.

User avatar
Posts: 8
Joined: Mon Jun 17, 2019 11:20 pm

Re: Tools setup - python packages dependency problem?

Postby TinkerBearNZ » Mon Jan 04, 2021 10:35 pm

Yep, the light just dawned this morning and I was back to reply to myself... and you beat me by 2 minutes. :oops:

Who is online

Users browsing this forum: No registered users and 54 guests