How to find where WDT timer failing

orbitcoms
Posts: 80
Joined: Fri Aug 03, 2018 10:08 pm

How to find where WDT timer failing

Postby orbitcoms » Tue May 25, 2021 5:45 am

I have a project that compiled and running ok. I then commented out one print statement and recompiled and flash and not I get a WDT timer error.
I uncommented the print line and still get this error.
Exited program, powered down hardware and tried again but it persists.

Below is copy of output. I am not sure how to zero in on the problem given this information. Thanks in advance

ets Jun 8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:1216
ho 0 tail 12 room 4
load:0x40078000,len:10944
load:0x40080400,len:6388
entry 0x400806b4
### DW1000-arduino-ranging-anchor ###
DW1000 initialized ...
Guru Meditation Error: Core 1 panic'ed (Interrupt wdt timeout on CPU1)
Core 1 register dump:
PC : 0x400885ea PS : 0x00060034 A0 : 0x80087a0b A1 : 0x3ffbea20
A2 : 0x3ffb8470 A3 : 0x3ffb8074 A4 : 0x00000001 A5 : 0x00000001
A6 : 0x00060023 A7 : 0x00000000 A8 : 0x3ffb8074 A9 : 0x3ffb8074
A10 : 0x00000018 A11 : 0x00000018 A12 : 0x00000001 A13 : 0x00000001
A14 : 0x00060021 A15 : 0x00000000 SAR : 0x00000013 EXCCAUSE: 0x00000006
EXCVADDR: 0x00000000 LBEG : 0x4000c428 LEND : 0x4000c42d LCOUNT : 0x00000000
Core 1 was running in ISR context:
EPC1 : 0x40086f0a EPC2 : 0x00000000 EPC3 : 0x00000000 EPC4 : 0x400885ea

ELF file SHA256: 0000000000000000

Backtrace: 0x400885ea:0x3ffbea20 0x40087a08:0x3ffbea40 0x4008603f:0x3ffbea60 0x400d3ef1:0x3ffbeaa0 0x400d1c01:0x3ffbeac0 0x400d20cb:0x3ffbeaf0 0x400d2209:0x3ffbeb20 0x400d2937:0x3ffbeb40 0x40080f19:0x3ffbeb60
0x40083911:0x3ffbeb80 0x400d4015:0x3ffb1e30 0x400d1c32:0x3ffb1e50 0x400d2410:0x3ffb1e70 0x400d24e1:0x3ffb1ea0 0x400d316b:0x3ffb1ec0 0x400d10d0:0x3ffb1ef0 0x400d4a7a:0x3ffb1fb0 0x40086205:0x3ffb1fd0

Core 0 register dump:
PC : 0x40086f0a PS : 0x00060034 A0 : 0x800876d1 A1 : 0x3ffbe500
A2 : 0x3ffbdf64 A3 : 0x0000cdcd A4 : 0xb33fffff A5 : 0x00000001
A6 : 0x00060021 A7 : 0x0000abab A8 : 0x0000abab A9 : 0x3ffc05c0
A10 : 0x00000003 A11 : 0x00060023 A12 : 0x00060021 A13 : 0x00000020
A14 : 0x00000020 A15 : 0x00000000 SAR : 0x00000011 EXCCAUSE: 0x00000006
EXCVADDR: 0x00000000 LBEG : 0x00000000 LEND : 0x00000000 LCOUNT : 0x00000000

ELF file SHA256: 0000000000000000

Backtrace: 0x40086f0a:0x3ffbe500 0x400876ce:0x3ffbe530 0x400862ef:0x3ffbe550 0x40088469:0x3ffbe570 0x4008391a:0x3ffbe580 0x400ed047:0x3ffbc130 0x400e53d3:0x3ffbc150 0x4008769a:0x3ffbc170 0x40086205:0x3ffbc190

Rebooting...
ets Jun 8 2016 00:22:57

username
Posts: 246
Joined: Thu May 03, 2018 1:18 pm

Re: How to find where WDT timer failing

Postby username » Sat Jun 05, 2021 4:02 am

odds are your code is starving the RTOS. I would say you created a loop without any form of delay in it.

Who is online

Users browsing this forum: No registered users and 39 guests