ESP32 PICO kit V4 manual RESET required

tolo69
Posts: 8
Joined: Thu Nov 16, 2017 7:32 pm

ESP32 PICO kit V4 manual RESET required

Postby tolo69 » Sun Mar 18, 2018 8:52 am

Hi all,
I'm using ESP32 PICO kit V4. After flashing the SW starts execution properly. But after normal power ON, the SW doesn't start automaticly. I have to press the RESET (EN) button. How can I activate the automatic RESET after power ON ?

User avatar
kolban
Posts: 1572
Joined: Mon Nov 16, 2015 4:43 pm
Location: Texas, USA

Re: ESP32 PICO kit V4 manual RESET required

Postby kolban » Sun Mar 18, 2018 3:30 pm

What (if anything) is logged to the serial output of your device when you boot it?
Free book on ESP32 available here: https://leanpub.com/kolban-ESP32
Available for ESP32 consulting.

tolo69
Posts: 8
Joined: Thu Nov 16, 2017 7:32 pm

Re: ESP32 PICO kit V4 manual RESET required

Postby tolo69 » Sun Mar 18, 2018 6:47 pm

After pressing RESET (EN) the Serial Output logs the following:

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 188777542, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:956
load:0x40078000,len:0
load:0x40078000,len:11904
entry 0x40078a3c

freemovers
Posts: 1
Joined: Sun Apr 22, 2018 10:11 pm

Re: ESP32 PICO kit V4 manual RESET required

Postby freemovers » Mon Apr 23, 2018 3:45 am

Hi, did you ever find a solution for this issue. I noticed the same behavior on the ESP32-PICO-KIT.

freemovers
Posts: 1
Joined: Sun Apr 22, 2018 10:11 pm

Re: ESP32 PICO kit V4 manual RESET required

Postby freemovers » Tue May 01, 2018 2:55 am

I found a solution. On other ESP32 boards there is a pull-up resistor on the EN and IO0. The EN pin on the ESP32-PICO-KIT has this pull up resistor: https://dl.espressif.com/dl/schematics/ ... ematic.pdf.
The IO0 is missing this resistor and needs to be added. I didn't have a 10K resistor, but a 7.5K worked fine for me (see attached the solution, fortunately 3.3V is next to IO0.
WIN_20180430_19_47_43_Pro.jpg
WIN_20180430_19_47_43_Pro.jpg (243.85 KiB) Viewed 381 times

tolo69
Posts: 8
Joined: Thu Nov 16, 2017 7:32 pm

Re: ESP32 PICO kit V4 manual RESET required

Postby tolo69 » Sun May 06, 2018 2:18 pm

Thanks, for the hint. I can confirm, that this is the solution: I used a 10k resistor and it works for me too :)

Who is online

Users browsing this forum: No registered users and 5 guests