ESP-WROVER-KIT will not reset

timredfern
Posts: 24
Joined: Sun Feb 25, 2018 10:59 am

ESP-WROVER-KIT will not reset

Postby timredfern » Wed Mar 21, 2018 3:22 pm

Pressing the button marked EN is supposed to reset the ESP-WROVER-KIT.. however it doesn't work on mine (V3).

I can see on the schematic a circuit with 2 transistors and DTR/RTS which I think is UART 0.

Is anyone else having this problem? Very inconvenient.

Tim

WiFive
Posts: 1818
Joined: Tue Dec 01, 2015 7:35 am

Re: ESP-WROVER-KIT will not reset

Postby WiFive » Thu Mar 22, 2018 4:23 am

Have you checked the button itself with an ohmmeter?

timredfern
Posts: 24
Joined: Sun Feb 25, 2018 10:59 am

Re: ESP-WROVER-KIT will not reset

Postby timredfern » Thu Mar 22, 2018 11:06 am

The button seems fine.

I'm reading 1 ohm closed, 14 k ohm open (presume the open reading is from the rest of the circuit, rather than the switch itself)

User avatar
kolban
Posts: 1570
Joined: Mon Nov 16, 2015 4:43 pm
Location: Texas, USA

Re: ESP-WROVER-KIT will not reset

Postby kolban » Thu Mar 22, 2018 2:03 pm

I'm likely way off base here ... but aren't there two buttons? One labeled boot and the other EN. It is my loose thinking that it is the boot button which causes the ESP32 to restart and the EN button defines a boolean flag that can be read at boot time to allow the ESP32 to know which mode to boot up into. I'm not sure it actually means anything to press the EN button when the ESP32 is running. What do we think pressing EN by itself should actually do?
Free book on ESP32 available here: https://leanpub.com/kolban-ESP32
Available for ESP32 consulting.

timredfern
Posts: 24
Joined: Sun Feb 25, 2018 10:59 am

Re: ESP-WROVER-KIT will not reset

Postby timredfern » Thu Mar 22, 2018 2:29 pm

https://dl.espressif.com/doc/esp-idf/la ... r-kit.html

EN
Reset button: pressing this button resets the system.
Boot
Download button: holding down the Boot button and pressing the EN button initiates the firmware download mode. Then user can download firmware through the serial port.

User avatar
fly135
Posts: 213
Joined: Wed Jan 03, 2018 8:33 pm
Location: Orlando, FL

Re: ESP-WROVER-KIT will not reset

Postby fly135 » Thu Mar 22, 2018 6:48 pm

Just tried pressing the EN button on my ESP-WROVER-KIT and it caused a reboot.

John A

User avatar
loboris
Posts: 391
Joined: Wed Dec 21, 2016 7:40 pm

Re: ESP-WROVER-KIT will not reset

Postby loboris » Thu Mar 22, 2018 7:20 pm

Sometimes, if the sdcard is inserted and was used, the reset button (EN) may not work.

timredfern
Posts: 24
Joined: Sun Feb 25, 2018 10:59 am

Re: ESP-WROVER-KIT will not reset

Postby timredfern » Fri Mar 23, 2018 2:10 pm

I don't have an SDcard mounted.

Is my ESP-WROVER-KIT faulty?

timredfern
Posts: 24
Joined: Sun Feb 25, 2018 10:59 am

Re: ESP-WROVER-KIT will not reset

Postby timredfern » Tue Mar 27, 2018 9:50 am

I see this viewtopic.php?t=1655#p7748

"Also I have worked out that my EN/Reset button doesn't seem to work unless I have a serial connection open, very weird. I did read that there was an issue with some of the boards with the EN button, looks like mine is one of them."

Any way to identify the boards with this issue?

jakkubu
Posts: 3
Joined: Thu Mar 16, 2017 11:18 am

Re: ESP-WROVER-KIT will not reset

Postby jakkubu » Mon Jun 04, 2018 8:24 am

In my ESP-WROVER-KIT v3 EN button also doesn't reset the chip.

I noticed that Voltage on EN pin drops to 1,6V when EN button is pressed. Also when checking R46, R65 and R169 I always get 10K and on the schematics they are connected with 100K resistors. They are connected with Q1, Q2 and Q9 npn transistors, so I probably shouldn't show 100K (depends on your ohmmeter), but the measurements should show at least 33,3K (assuming parallel connection).

My guess is that they used smaller resistors. Because EN level depends on nRTS and nDTR levels (R1 pull up resistor is driving Q1 transistor), EN level doesn't fall enough to cause chip reset.

Currently I'm using EN pin for resetting.

Who is online

Users browsing this forum: Bing [Bot] and 2 guests