OpenOCD for ESP32-devkit-C with FT232HL on macOS

y-hira
Posts: 1
Joined: Thu Jun 21, 2018 10:02 am

OpenOCD for ESP32-devkit-C with FT232HL on macOS

Postby y-hira » Thu Jun 21, 2018 10:19 am

Hi, I am trying to use JTAG debugging on macOS 10.13.3.
I tried:
http://esp-idf.readthedocs.io/en/latest/api-guides/jtag-debugging/index.html

I made this file
ft232hl.cfg:

Code: Select all

interface ftdi
ftdi_vid_pid 0x0403 0x6014
ftdi_channel 0
reset_config none
adapter_khz 20000
transport select jtag



I connected FT232HL adapter to MacBook, and can see vid: 0x0403, pid: 0x6014 device on System Information.app.
Then

Code: Select all

$ openocd -f ft232hl.cfg -f target/esp32.cfg
Open On-Chip Debugger 0.10.0-dev-00003-ga9ec3301 (2018-06-07-17:20)
Licensed under GNU GPL v2
For bug reports, read
   http://openocd.org/doc/doxygen/bugs.html
none separate
adapter speed: 20000 kHz
jtag
esp32 interrupt mask on
force hard breakpoints
Error: libusb_claim_interface() failed with LIBUSB_ERROR_ACCESS
Error: unable to open ftdi device with vid 0403, pid 6014, description '*', serial '*' at bus location '*'


and I tried:

Code: Select all

~ sudo kextunload -p -b com.apple.driver.AppleUSBFTDI
~ sudo kextutil -b com.apple.driver.AppleUSBFTDI -p AppleUSBEFTDI-6010-1

and connected FT232HL again, but nothing changed.

How can I use OpenOCD for ESP32-devkit-C with FT232HL on macOS?

w19787
Posts: 4
Joined: Tue Jun 26, 2018 1:56 pm

Re: OpenOCD for ESP32-devkit-C with FT232HL on macOS

Postby w19787 » Mon Jul 02, 2018 3:21 am

please try:
sudo kextunload -bundle-id com.FTDI.driver.FTDIUSBSerialDriver

but this is a negative impact, the uart channel has been closed as well. i don't have solution for this yet.

Who is online

Users browsing this forum: ESP_Sprite and 7 guests