Page 1 of 1

(Noob) Schematic Question

Posted: Sun Jul 22, 2018 1:11 pm
by hotsnot101
Hi everyone!

I've created a breakout board for the ESP-WROOM-32 and I'm trying to figure out if there is something wrong with my (boiled down) schematic:
Screen Shot 2018-07-22 at 9.01.33 PM.png
Screen Shot 2018-07-22 at 9.01.33 PM.png (99.64 KiB) Viewed 946 times
Is there any reason this schematic would not enable me to have a working breakout board for just programming? I've conducted an open short test on my PCB, and everything looks fine. I've also only soldered these points - so I'm wondering if this is wrong, or maybe I have a bad component.

Thanks!

Re: (Noob) Schematic Question

Posted: Mon Jul 23, 2018 11:22 am
by f.h-f.s.
Have a look at the DevKitC schematic at https://dl.espressif.com/dl/schematics/ ... V2_sch.pdf
I think the problem is located on your IO0 and EN lines, but that's just a guess. That schematic is a great reference though ;)

Re: (Noob) Schematic Question

Posted: Mon Jul 23, 2018 11:49 am
by Vader_Mester
I suggest you implement this circuit (see below pic). This will enable you to use any external UART interface.
Also, please place a 0,1uF capacitor to the EN pin. This can be a 10% regural ceramic cap, 25V, which is used in every dev board.

There were other notations on the forum with some timing issue, that the EN pin must be pulled high later than the IO0. This capacitor does just that. While it charges, it will keep the signal low for long enough, so the proper programming mode to be entered.
I suggest reading this topic. about this issue.
ESP32_Uart_prog.JPG
ESP32_Uart_prog.JPG (30.27 KiB) Viewed 898 times