BLE pairing with iPhone and Android

dgube1
Posts: 2
Joined: Fri Aug 10, 2018 5:41 am

BLE pairing with iPhone and Android

Postby dgube1 » Tue Aug 14, 2018 3:09 pm

Having an issue where an Android device running the same app as an iPhone is seeing different BLE Characteristics and am not sure why this may be. The characteristics seen by the iPhone are the the correct but when switching to the Android platform it is seeing the id for an old characteristic that has been removed from the esp32's application.

iOS and Android development is not my realm of expertise so if anyone could shed some light on why the two are seeing different information that would be much appreciated.

chegewara
Posts: 426
Joined: Wed Jun 14, 2017 9:00 pm

Re: BLE pairing with iPhone and Android

Postby chegewara » Wed Aug 15, 2018 12:58 pm

Most likely its because android is caching device information in ble to lower power consumption.

JoaoLopesF
Posts: 51
Joined: Thu Aug 17, 2017 5:40 pm

Re: BLE pairing with iPhone and Android

Postby JoaoLopesF » Thu Aug 16, 2018 9:54 pm

Hi, I use ESP32 with Android (>= 4.0.3) and iOS (10.3 and 11.3).

Both working very well with ESP32 BLE.
I not have any cache problem with Android, as related by @chegewara.

I suggest You use the nRF Toolbox app, of Nordic, in both iOS and Android.
This is very complete tool app to BLE devices.

I just finish the Esp-Idf-Mobile-Apps github repos (ESP32 and IOS. Android soon).
Please give a look https://www.esp32.com/viewtopic.php?f=18&t=6806

Vou can try connect your mobiles app with this ESP-IDF sample, to identify if the problem is
in Android app or in ESP-IDF app.
I suspect in this, I have problems to connect ESP32 with mobiles.
I can it only with ble_uart_sample of @pcbreflux, another libs/examples not worked with me

Who is online

Users browsing this forum: jeanleflambeur and 11 guests