Unable to upload.

Beb1969
Posts: 5
Joined: Fri Dec 09, 2016 3:06 pm

Unable to upload.

Postby Beb1969 » Fri Dec 09, 2016 3:12 pm

Hello,

I'm new to the ESP32. I am struggling to upload any to the Nano32. My setup is a Windows 10 laptop. I'm using esp-idf version 1. When trying to the chip, I get the following information :

Code: Select all

$ make flash
C:/esp32idf/esp-idf/make/component_common.mk:1: Deprecated feature: No longer necessary to include component_common.mk from C:/esp32idf/esp-idf/components/bt/component.mk
Flashing binaries to serial port COM8 (app at offset 0x10000)...
esptool.py v2.0-dev
Connecting...
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 921600
Changed.
Attaching SPI flash...
Configuring flash size...
Erasing flash...
Took 0.02s to erase flash block
Wrote 16384 bytes at 0x00001000 in 0.2 seconds (699.1 kbit/s)...

A fatal error occurred: Timed out waiting for packet header
make: *** [C:/esp32idf/esp-idf/components/esptool_py/Makefile.projbuild:48: flash] Error 2
Hopefully, someone maybe able to help me. Thank you in advance,

Beb

ESP_Angus
Posts: 2344
Joined: Sun May 08, 2016 4:11 am

Re: Unable to upload.

Postby ESP_Angus » Sun Dec 11, 2016 10:31 pm

Hi Beb,

It looks like it's mostly working and then something is interrupting the connection.

- If you change the default baud rate (under "make menuconfig", Serial Port Flashing Settings) to 115200, does anything change?

- Is it possible some other software running on your computer may be trying to access the USB serial port?

- If you change USB ports or use a different USB cable, does anything change?

Beb1969
Posts: 5
Joined: Fri Dec 09, 2016 3:06 pm

Re: Unable to upload.

Postby Beb1969 » Mon Dec 19, 2016 10:18 am

Hi,

Thanks for the reply.

I still cant upload. Tried changing to 115200, turning off my virus scanner, changed my usb cable, and still no joy. I will carrying on hoping to succeed in uploading.

Beb

ESP_Angus
Posts: 2344
Joined: Sun May 08, 2016 4:11 am

Re: Unable to upload.

Postby ESP_Angus » Mon Dec 19, 2016 9:26 pm

Do you have a different computer you can try it on? It may be you have faulty hardware.

ESP_igrr
Posts: 1709
Joined: Tue Dec 01, 2015 8:37 am

Re: Unable to upload.

Postby ESP_igrr » Tue Dec 20, 2016 4:40 am

Also IIRC on Windows you may need to press "Boot" button before uploading and hold it until the upload starts.

Beb1969
Posts: 5
Joined: Fri Dec 09, 2016 3:06 pm

Re: Unable to upload.

Postby Beb1969 » Wed Dec 21, 2016 11:03 am

Thank you all for the help.

Ive reached a point with the nano32 where I can upload some code, but get a MD5 error.

However, Ive now also got a node32s, where there is no issue with uploading code, all works fine on this one. So either my nano32 doesnt work, or there is something else wrong.

Thanks

Beb

Who is online

Users browsing this forum: No registered users and 30 guests