VC 6.0 is not supported

GauriS
Posts: 1
Joined: Tue Sep 25, 2018 7:55 am

VC 6.0 is not supported

Postby GauriS » Tue Sep 25, 2018 7:58 am

I am trying to set-up ESP-IDF for my windows 10 laptop. When I try to install the required python packages, I get following error:
distutils.errors.DistutilsPlatformError: VC 6.0 is not supported by this module

chegewara
Posts: 815
Joined: Wed Jun 14, 2017 9:00 pm

Re: VC 6.0 is not supported

Postby chegewara » Tue Sep 25, 2018 3:24 pm

I am using laptop with windows 10 and i have no issue with esp-idf. Did you follow this to install environment:
https://docs.espressif.com/projects/esp ... setup.html

oclyke
Posts: 2
Joined: Thu Sep 27, 2018 6:27 am

Re: VC 6.0 is not supported

Postby oclyke » Thu Sep 27, 2018 6:33 am

Hello, I am having the same trouble as GuariS. I have set up the path variable so that "printenv IDF_PATH" produces the correct path within MSYS2.

Here's my error output:

$ python -m pip install --user -r $IDF_PATH/requirements.txt
Requirement already satisfied: setuptools in d:/programfiles/msys32/mingw32/lib/python2.7/site-packages (from -r D:\Progr amFiles\msys32\home\myname\esp\esp-idf/requirements.txt (line 4)) (40.4.3)
Requirement already satisfied: pyserial>=3.0 in d:/programfiles/msys32/mingw32/lib/python2.7/site-packages (from -r D:\Pr ogramFiles\msys32\home\myname\esp\esp-idf/requirements.txt (line 8)) (3.4)
Collecting future>=0.16.0 (from -r D:\ProgramFiles\msys32\home\OwenLyke\esp\esp-idf/requirements.txt (line 9))
Using cached https://files.pythonhosted.org/packages ... 9ae3e81e85 /future-0.16.0.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "D:/ProgramFiles/msys32/mingw32/lib/python2.7/site-packages/setuptools/__init__.py", line 191, in <module>
monkey.patch_all()
File "D:/ProgramFiles/msys32/mingw32/lib/python2.7/site-packages/setuptools/monkey.py", line 101, in patch_all
patch_for_msvc_specialized_compiler()
File "D:/ProgramFiles/msys32/mingw32/lib/python2.7/site-packages/setuptools/monkey.py", line 164, in patch_for_msvc _specialized_compiler
patch_func(*msvc9('find_vcvarsall'))
File "D:/ProgramFiles/msys32/mingw32/lib/python2.7/site-packages/setuptools/monkey.py", line 151, in patch_params
mod = import_module(mod_name)
File "D:/ProgramFiles/msys32/mingw32/lib/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "D:/ProgramFiles/msys32/mingw32/lib/python2.7/distutils/msvc9compiler.py", line 306, in <module>
raise DistutilsPlatformError("VC %0.1f is not supported by this module" % VERSION)
distutils.errors.DistutilsPlatformError: VC 6.0 is not supported by this module

Command "python setup.py egg_info" failed with error code 1 in c:/users/owenly~1/appdata/local/temp/pip-install-vrqkhf/fu ture/


Frankly I have little to no clue what it means. Can anyone point me in the right direction to solve this?

Thanks for your time!

ESP_igrr
Posts: 1515
Joined: Tue Dec 01, 2015 8:37 am

Re: VC 6.0 is not supported

Postby ESP_igrr » Thu Sep 27, 2018 9:58 am

Please try the suggestion from this post: https://esp32.com/viewtopic.php?f=13&t=7419#p31342

ESP_Angus
Posts: 1815
Joined: Sun May 08, 2016 4:11 am

Re: VC 6.0 is not supported

Postby ESP_Angus » Mon Oct 01, 2018 5:30 am

Also probably the suggestion here:
https://github.com/espressif/esp-idf/is ... -425790054

An updated MSYS2 environment will be available ASAP.

Milan991
Posts: 9
Joined: Mon Jun 18, 2018 10:02 pm

Re: VC 6.0 is not supported

Postby Milan991 » Mon Oct 01, 2018 9:33 pm

Yes, that was the solution. Thank you.

Who is online

Users browsing this forum: Bing [Bot] and 18 guests