jump to run addr @ 0x40000

captain_morgan
Posts: 34
Joined: Wed Dec 09, 2015 6:39 pm

jump to run addr @ 0x40000

Postby captain_morgan » Thu Dec 24, 2015 10:09 pm

I've made a ton of progress so far. Having got my dev env setup before the module arrive, I'm not compiling and uploading code. The problem I'm currently facing is the issue of the device generally not wanting to boot. 9 out of 10 times I get stuck with this.
jump to run addr.png
jump to run addr.png (15.91 KiB) Viewed 6480 times
If I keep rebooting the device eventually the code runs. Any tips?

captain_morgan
Posts: 34
Joined: Wed Dec 09, 2015 6:39 pm

Re: jump to run addr @ 0x40000

Postby captain_morgan » Fri Dec 25, 2015 1:33 am

Sometimes the garbage out put is different, or nothing is output after 0x40000.
Occasionally I will also see a reboot with cause: 12

captain_morgan
Posts: 34
Joined: Wed Dec 09, 2015 6:39 pm

Re: jump to run addr @ 0x40000

Postby captain_morgan » Fri Dec 25, 2015 3:51 am

This could possible be a power supply issue. I haven't change anything there, but when I have the power running through my multimeter it boots reliably. Idles ~103mA

User avatar
rudi ;-)
Posts: 1405
Joined: Fri Nov 13, 2015 3:25 pm

Re: jump to run addr @ 0x40000

Postby rudi ;-) » Fri Dec 25, 2015 1:07 pm

captain_morgan wrote:This could possible be a power supply issue. I haven't change anything there, but when I have the power running through my multimeter it boots reliably. Idles ~103mA
hi david,
can you use a scope and sets the trigger little under the highest peak value.
then at least post the highest value you get. idles ~103mA this comes from a multimeter?
can this multimeter perhabs catch a "fast current peak" and the 103 mA is the highest peak? thank you!

best wishes
rudi ;-)
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

captain_morgan
Posts: 34
Joined: Wed Dec 09, 2015 6:39 pm

Re: jump to run addr @ 0x40000

Postby captain_morgan » Fri Dec 25, 2015 7:20 pm

David?! Whatever...

Yes, the multimeter is indicating consumption of just over 100mA most of the time.
Anyhow.. this isn't my biggest issue at the moment.

johnlee
Posts: 33
Joined: Sun Nov 15, 2015 4:27 am

Re: jump to run addr @ 0x40000

Postby johnlee » Sat Dec 26, 2015 10:06 am

103mA doesn't seem the kind of number that we are expecting during boot. we need to check on this...

Baoshi
Posts: 14
Joined: Sun Nov 22, 2015 3:30 am

Re: jump to run addr @ 0x40000

Postby Baoshi » Sat Dec 26, 2015 3:18 pm

Hi,

Below are the current measurements, taking using eevblog uCurrent, 1mV = 1mA

Bootup, some spikes goes as high as 700mA, afterwards stable at 100mA
DS1ED141303193_0.png
Bootup
DS1ED141303193_0.png (6.82 KiB) Viewed 6386 times
Idle (SoftAP, no client connected)
DS1ED141303193_1.png
Idle
DS1ED141303193_1.png (6.01 KiB) Viewed 6386 times
Zoomin of the spikes in Idle state
DS1ED141303193_3.png
Zoomin of Idle
DS1ED141303193_3.png (6.39 KiB) Viewed 6386 times
I feel these are on the high side. My simple 5V-3.3V stepdown using 1117-3.3 does not give stable result.

Baoshi
Posts: 14
Joined: Sun Nov 22, 2015 3:30 am

Re: jump to run addr @ 0x40000

Postby Baoshi » Sat Dec 26, 2015 3:19 pm

Seems the forum does not allow me to upload more than 3 attachments.
This is the current measurement during busy state
DS1ED141303193_2.png
Busy state
DS1ED141303193_2.png (6.83 KiB) Viewed 6386 times

User avatar
rudi ;-)
Posts: 1405
Joined: Fri Nov 13, 2015 3:25 pm

Re: jump to run addr @ 0x40000

Postby rudi ;-) » Sat Dec 26, 2015 3:31 pm

txs baoshi

can confirm this.

have not test byself with rigol just in time, but the usb ( 500 mA ) is sometimes short time overloaded and break down.

Test with a USB TTL adapter and simultaneous power supply of this was mostly satisfactory. therefore I have made over a USB TTL Adpater the power supply and the UART.

However, sometimes overloaded and breaks every now and then the com driver off therefore.

so then I went back to the Back Route stable power supply.

thanks

best wishes
rudi ;-)
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

User avatar
rudi ;-)
Posts: 1405
Joined: Fri Nov 13, 2015 3:25 pm

Re: jump to run addr @ 0x40000

Postby rudi ;-) » Sat Dec 26, 2015 4:39 pm

-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

Who is online

Users browsing this forum: No registered users and 20 guests