sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C

czuvich
Posts: 19
Joined: Tue Sep 04, 2018 1:58 am

sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C

Postby czuvich » Wed Dec 05, 2018 6:21 pm

I just purchased the WROVER dev kit, and I tried following the Getting Started Guide. I am able to get the menuconfig to come up; however, when I try to run "make flash" for the Hello World application, I am getting the following error:

sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C

I am running on a Mac (Mojave). Any help is greatly appreciated!

ESP_Angus
Posts: 1318
Joined: Sun May 08, 2016 4:11 am

Re: sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C

Postby ESP_Angus » Wed Dec 05, 2018 10:52 pm

Hi czuvich,

Can you please post the output of the command "git describe --tags --dirty"

and please also post the full output of the "make" command (all lines).


Angus

czuvich
Posts: 19
Joined: Tue Sep 04, 2018 1:58 am

Re: sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C

Postby czuvich » Thu Dec 06, 2018 5:43 pm

The output of "git describe --tags --dirty" in the hello_world directory is:

Code: Select all

"fatal: not a git repository (or any of the parent directories): .git"
The full output of "make flash":

Code: Select all

Toolchain path: /Users/XXX/esp/xtensa-esp32-elf/bin/xtensa-esp32-elf-gcc
Toolchain version: crosstool-ng-1.22.0-80-g6c4433a
Compiler version: 5.2.0
Python requirements from /Users/XXX/esp/esp-idf/requirements.txt are satisfied.
fatal: not a git repository (or any of the parent directories): .git
Project do not have git repo, it needs to get PROJECT_VER from `git describe` command.
App "hello-world" version: ""
CC build/app_update/esp_app_desc.o
AR build/app_update/libapp_update.a
Generating libapp_update.a.sections_info
sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C
make: *** [/Users/XXX/esp/hello_world/build/ldgen.section_infos] Error 1
[code]

ESP_Angus
Posts: 1318
Joined: Sun May 08, 2016 4:11 am

Re: sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C

Postby ESP_Angus » Thu Dec 06, 2018 10:28 pm

Sorry, I gave you incomplete information - please run the "git describe --tags --dirty" in the IDF_PATH directory not the project directory.

Also, a fix was merged to master yesterday for cross-platform sed usage. If you pull the latest IDF master branch from github, it will hopefully fix this error.

Reiner1210
Posts: 19
Joined: Tue Mar 20, 2018 6:28 pm

Re: sed: 1: "/Users/XXX/esp/hello_w ...": invalid command code C

Postby Reiner1210 » Tue Dec 11, 2018 8:33 am

I have the same after updating and build my projekt.

fatal: Kein Git-Repository (oder irgendeines der Elternverzeichnisse): .git
Project do not have git repo, it needs to get PROJECT_VER from `git describe` command

v3.3-beta1-4-g23b6d40c5-dirty

Who is online

Users browsing this forum: axellin and 19 guests