Page 1 of 1

Getting Started

Posted: Tue Jan 01, 2019 3:40 pm
by rowan.bradley
I have an ESP32 development board made by DIYmore. If I power it up the blue LED flashes, and the red LED is permanently on. I have tried loading a sketch from the Arduino IDE, but I get this:

Sketch uses 599086 bytes (45%) of program storage space. Maximum is 1310720 bytes.
Global variables use 41484 bytes (12%) of dynamic memory, leaving 286196 bytes for local variables. Maximum is 327680 bytes.
esptool.py v2.3.1
Connecting........_____....._____....._____....._____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header
A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

It is clearly not communicating with the ESP32.

What may be wrong?

How do I load the correct board definition into Arduino IDE so that it recognises this board type?

Or is the DIYmore board equivalent to some board type that the IDE already recognises?

What drivers do I need to load on my PC (Windowsd 8.1) in order to communicate correctly with the ESP32?

Re: Getting Started

Posted: Wed Jan 02, 2019 1:16 am
by SuperTechSaiyan3
for drivers make sure you have the CP2102 driver it should pop up under COM ports in device manager.

having said that, I had this same exact issue with the blue light flashing, that I recently fixed, here are my suggestions that fixed mine:

1. use esp flash tool to wipe all data on the ESP, then try to program it.

2. what GPIO pins are your using? use different ones, I think using GPIO 2 or 4 was causing my issue

Re: Getting Started

Posted: Thu Jan 03, 2019 4:17 pm
by OutOfLine
Many boards come with 2 buttons
different boards may give them different names, so just try...

when the Connecting..... line starts building up press one of the buttons for a few seconds
then release

if it does not start uploading repeat with the other one

Re: Getting Started

Posted: Thu Jan 03, 2019 5:12 pm
by rowan.bradley
That sorted it thank you. Yes, there are two buttons on the board (marked Boot, and EN), as well as an On/Off switch. I had to press the Boot button, then it started to load correctly, and the sketch ran successfully. Why isn;t this mentioned in the official documentation somewhere? Or have I just not found the correct documentation?

Anyway, thanks for your help. Now I will try writing some code of my own.

Thanks - Rowan

Re: Getting Started

Posted: Fri Jan 04, 2019 5:57 am
by OutOfLine
Many boards do enter flash mode automatically, some don't and you have to press the button. I guess it is a problem in the board design.

Re: Getting Started

Posted: Fri Jan 04, 2019 2:35 pm
by fly135
It's not just the boards. It's also the USB. I have a USB extension cable attached to a desktop and I have to hold BOOT while toggling EN to get it to load. But if I connect the same board to my laptop with a short USB cable it will automatically download with no button press.

John A

Re: Getting Started

Posted: Wed Jan 09, 2019 1:11 am
by 2strokespower
Hi everybody,

I also am trying to use the ESP32 with ArduinoIDE.

I follow the steps of the following video tutorial: https://www.youtube.com/watch?v=hjJx6QOWVkU.

The problem is that when I try to verify the WiFiScan example I just get the same message.
Error.png
Error.png (42.84 KiB) Viewed 1097 times
Can, please, someone help me or give me some orientation.

Regards,
Diogo Cruz

Re: Getting Started

Posted: Wed Jan 09, 2019 3:35 am
by SuperTechSaiyan3
Hey Diogo,

your image does not show an error can you show it?

if it is same as the OP, try the technique above where you press the buttons, if that does not work and you see a blue LED try my method above.

Re: Getting Started

Posted: Wed Jan 09, 2019 6:18 pm
by 2strokespower
The error was the following:
A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

I manage to upload the example WiFiScan to the ESP32, holding down the boot button before starting the upload and stop holding the boot button after realize that was uploading.
Solved.png
Solved.png (55.42 KiB) Viewed 1046 times
Thanks for the help.