Unable to setup esp AT commands bin

wnoliveira
Posts: 5
Joined: Wed Feb 06, 2019 6:45 pm

Unable to setup esp AT commands bin

Postby wnoliveira » Wed Feb 06, 2019 6:54 pm

Hi all.

I am trying yo setup the at-commands module by flashing the esp-at.bin into the esp32 flash. However, I've trie to follow all the instructions on AT commands PDF and also some videos, but nothing works yet.

In the last AT version (https://www.espressif.com/en/support/download/at - V1.13) the avaiable bin files are:
-> at_customize;
-> blank;
-> esp-at;
-> factory;
-> partitions_at;
-> phy_init_data.

Which files I must download to esp, and in what address?

If someone can explain, I will be very aprecciated :D .

Regards.

ESP_Sprite
Posts: 2278
Joined: Thu Nov 26, 2015 4:08 am

Re: Unable to setup esp AT commands bin

Postby ESP_Sprite » Thu Feb 07, 2019 4:29 am

Have you looked at section 1.2 of the AT documentation?

wnoliveira
Posts: 5
Joined: Wed Feb 06, 2019 6:45 pm

Re: Unable to setup esp AT commands bin

Postby wnoliveira » Thu Feb 07, 2019 10:37 am

Definitely.

But it's really not clarifying to what I should download at what addr... :?

ESP_igrr
Posts: 1368
Joined: Tue Dec 01, 2015 8:37 am

Re: Unable to setup esp AT commands bin

Postby ESP_igrr » Thu Feb 07, 2019 11:35 am

The flashing addresses are in /ESP32_AT_BIN/download.config.

wnoliveira
Posts: 5
Joined: Wed Feb 06, 2019 6:45 pm

Re: Unable to setup esp AT commands bin

Postby wnoliveira » Thu Feb 07, 2019 12:41 pm

ESP_igrr wrote:
The flashing addresses are in /ESP32_AT_BIN/download.config.

Ok, I didn't notice that. That helps me a lot!

I successfully downloaded the binaries, as you can see in the module's response in my serial monitor:

Image

However, the module doesn't answer the "AT"+CR+LF echo test. The initialization is correct?

wnoliveira
Posts: 5
Joined: Wed Feb 06, 2019 6:45 pm

Re: Unable to setup esp AT commands bin

Postby wnoliveira » Thu Feb 07, 2019 2:10 pm

Hi all.

Problem solved :D

The default serial for AT commands are not the same that show logs and download the bin. There is another serial for that.

All is working fine now.

Thanks a lot for the help.

harthenry
Posts: 2
Joined: Mon Dec 17, 2018 1:31 pm

Re: Unable to setup esp AT commands bin

Postby harthenry » Fri Feb 15, 2019 8:18 pm

Can you post how you accomplished this task -- I am in the same boat

Return to “General Discussion”

Who is online

Users browsing this forum: __vnv__ and 19 guests