Invalid project path on Eclipse

User avatar
gunar.kroeger
Posts: 142
Joined: Fri Jul 27, 2018 6:48 pm

Invalid project path on Eclipse

Postby gunar.kroeger » Fri Mar 22, 2019 4:22 pm

Hi everyone,

After I moved all my header files from main folder to main/include folder following a component structure, I get this warnings in Eclipse:

Code: Select all

Description	Resource	Path	Location	Type
Invalid project path: Include path not found (\c\Users\gunar.kroeger\Desktop\eclipse\ESP32_Project\main\include).
ESP32_Project		pathentry	Path Entry Problem

Description	Resource	Path	Location	Type
Invalid project path: Include path not found (C:\msys32\home\gunar.kroeger\esp\esp-idf\components\http_server\include).
ESP32_Project		pathentry	Path Entry Problem
Everything is configured following the Getting Started documentation for Eclipse on Windows
Any ideas?
"Running was invented in 1612 by Thomas Running when he tried to walk twice at the same time."

User avatar
rudi ;-)
Posts: 1502
Joined: Fri Nov 13, 2015 3:25 pm

Re: Invalid project path on Eclipse

Postby rudi ;-) » Fri Mar 22, 2019 7:05 pm

gunar.kroeger wrote:
Fri Mar 22, 2019 4:22 pm

..Any ideas?
windows or linux?
- it looks like windows.

it would help if you could post the eclipse setup to the project.. ( properties )

how you have IDF path setup in eclipse?

look to this (project) example..
eclipse_idf_path_example_windows.jpg
eclipse_idf_path_example_windows.jpg (126.89 KiB) Viewed 1605 times
and have a note to slashes and backslashes
search PATH and IDF PATH

hope this helps
best wishes
rudi ;-)

edit:
What you can check also:
- was in makefile an entry before you move the header so you must edit this too
- was in component.mk an entry before you move the header so you must edit this too
- usually i have in the main no include directory - i have it in the project and this is the PWD Path so it would be enough with a point .
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

User avatar
gunar.kroeger
Posts: 142
Joined: Fri Jul 27, 2018 6:48 pm

Re: Invalid project path on Eclipse

Postby gunar.kroeger » Fri Mar 22, 2019 8:17 pm

Yes, I'm on windows.

Project settings are equivalent to the one you posted:
Capture.PNG
Capture.PNG (38.99 KiB) Viewed 1600 times
And this is my Makefile:

Code: Select all

PROJECT_NAME := ESP32_Project

include $(IDF_PATH)/make/project.mk

fullflash:
	python ${IDF_PATH}/components/esptool_py/esptool/esptool.py --chip esp32 --port COM4 --baud 921600 --before default_reset --after hard_reset write_flash -z --flash_mode dio --flash_freq 40m --flash_size detect 0xd000 ${PWD_UPDATER}/build/ota_data_initial.bin 0x1000 ${PWD_UPDATER}/build/bootloader/bootloader.bin 0x10000 ${PWD_UPDATER}/build/ESP32_Updater.bin 0x90000 ${PWD}/build/ESP32_Project.bin 0x8000 ${PWD_UPDATER}/build/partitions.bin
component.mk:

Code: Select all

#
# Main component makefile.
#
# This Makefile can be left empty. By default, it will take the sources in the 
# src/ directory, compile them and link them into lib(subdirectory_name).a 
# in the build directory. This behaviour is entirely configurable,
# please read the ESP-IDF documents if you need to do this.
#
CFLAGS += -Wno-format

COMPONENT_EMBED_TXTFILES := howsmyssl_com_root_cert.pem
Do you see any mistake I'm not seeing?

Thanks
"Running was invented in 1612 by Thomas Running when he tried to walk twice at the same time."

User avatar
rudi ;-)
Posts: 1502
Joined: Fri Nov 13, 2015 3:25 pm

Re: Invalid project path on Eclipse

Postby rudi ;-) » Fri Mar 22, 2019 9:07 pm

gunar.kroeger wrote:
Fri Mar 22, 2019 8:17 pm
Project settings are equivalent to the one you posted:
...
..

Do you see any mistake I'm not seeing?
PWD does have this double Backslashes at ${USERNAME}

IDF_PATH
a) i see backslahes instead slashes
b) why there is double backslashes on ${USERNAME} ?
usually if you use variables and insert this ${USERNAME} then there is no backslahes extra inserted, only ${USERNAME}
example: c:\blabla\dada\${USERNAME}
yours looks so: c:\blabla\dada\\${USERNAME}\.....
and should look: c:/blabla/dada/${USERNAME}/.........

view1.jpg
view1.jpg (19.42 KiB) Viewed 1596 times
also in
view2.jpg
view2.jpg (24.77 KiB) Viewed 1596 times
was this before same setup where your compile runs before you did the move of headers?
and did the compile runs without error?

btw how you setup the makefile things:
( Build command )
view3.jpg
view3.jpg (121.23 KiB) Viewed 1596 times
can you post the few start lines of LOG if you start the compile
example: target "make app"

Code: Select all

21:43:06 **** Build of configuration Default for project 7202_helloworld ****
python c:/sdk32/esp-idf-7202/tools/windows/eclipse_make.py -j5 app 
Running make in 'C:/Users/sunce/eclipse-workspace-oxygen/7202_helloworld'
including C:/sdk32/esp-idf-7202/components/app_update/Makefile.projbuild...
including C:/sdk32/esp-idf-7202/components/bootloader/Makefile.projbuild...
including C:/sdk32/esp-idf-7202/components/bootloader_support/Makefile.projbuild...

best wishes
rudi ;-)
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

User avatar
gunar.kroeger
Posts: 142
Joined: Fri Jul 27, 2018 6:48 pm

Re: Invalid project path on Eclipse

Postby gunar.kroeger » Sat Mar 23, 2019 1:50 pm

rudi ;-) wrote: was this before same setup where your compile runs before you did the move of headers?
and did the compile runs without error?
yes, for both.

build command = python ${IDF_PATH}/tools/windows/eclipse_make.py -j5
build directory = ${workspace_loc:/ESP32_Project}/

I changed all the backslashes to forward slashes and removed the double backslashes as well. Did a clean project, deleted the warnings and build the project again. Sadly, the 2 warnings about Invalid project path reappeared ):

Code: Select all

python C:/msys32/home/gunar.kroeger/esp/esp-idf/tools/windows/eclipse_make.py -j5 all size 
Running make in 'C:/Users/gunar.kroeger/Desktop/eclipse/ESP32_Ziegesauger'
including C:/msys32/home/gunar.kroeger/esp/esp-idf/components/app_update/Makefile.projbuild...
including C:/msys32/home/gunar.kroeger/esp/esp-idf/components/bootloader/Makefile.projbuild...
including C:/msys32/home/gunar.kroeger/esp/esp-idf/components/bootloader_support/Makefile.projbuild...
"Running was invented in 1612 by Thomas Running when he tried to walk twice at the same time."

User avatar
rudi ;-)
Posts: 1502
Joined: Fri Nov 13, 2015 3:25 pm

Re: Invalid project path on Eclipse

Postby rudi ;-) » Sat Mar 23, 2019 7:02 pm

gunar.kroeger wrote:
Sat Mar 23, 2019 1:50 pm
rudi ;-) wrote: was this before same setup where your compile runs before you did the move of headers?
and did the compile runs without error?
yes, for both.

Sadly, the 2 warnings about Invalid project path reappeared ):

ok , for better understand:
you have a project in eclipse
named: myProj
then in the myProj you have main folder
in the main folder you have the include folder and header's moved in the main now

did you change in the src file / header files the include order then too?

you want do the main likewise an Component - so did you try
COMPONENT_ADD_INCLUDEDIRS and COMPONENT_SRCDIRS

to the main/include ?

try it.

usually project

best wishes
rudi ;-)


edit:
gunar.kroeger wrote: "After I moved all my header files from main folder to main/include folder following a component structure"
this i mean -
did you then change in the src files in the main folder the "new" header place?
how looks a src file in the main ?
Can you post the header include part?

Code: Select all

Description	Resource	Path	Location	Type
Invalid project path: Include path not found (\c\Users\gunar.kroeger\Desktop\eclipse\ESP32_Project\main\include).
ESP32_Project		pathentry	Path Entry Problem

Description	Resource	Path	Location	Type
Invalid project path: Include path not found (C:\msys32\home\gunar.kroeger\esp\esp-idf\components\http_server\include).
ESP32_Project		pathentry	Path Entry Problem
a folder "include" in the main exist?
a folder "include" in the "....components\http_server" exist?

what have you done
- "moved all my header files from main folder to main/include folder"
what have you done further?
- changed the include dir in makefile?
- changed the include dir in the component file?
- changed the #include in the src file which are in the main?

few things you must further do :
but i am out of my level now - perhabs you can post the project files?
there is something now missing or be wrong in the src files -
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

Who is online

Users browsing this forum: Baidu [Spider] and 43 guests