Using libesp-tremor directtly fails on av_open_callbacks

philippe_44
Posts: 8
Joined: Thu May 23, 2019 3:05 pm

Using libesp-tremor directtly fails on av_open_callbacks

Postby philippe_44 » Thu May 23, 2019 3:15 pm

Hi - I'm trying to use tremor with libesp-tremor.a (instead of compiling myself tremor). Strangely, my application fails when calling ov_open_callbacks, it returns an OV_EREAD but my read callback is not even called. The exact same code works fine when compile on my x86 or arm Linux box. All the callbacks except read are set to NULL (I've tried with non-NULL callbacks as well).

The only thing I can think of is that my datasource points to an object of my own that is not of any kind knows by esp-idf, but that why you do have callbacks that pass you back that datasource, don't you?

When I compile tremor directly, it works but consumes 16k of stacks which I'm unhappy with, so I could need to find out why (using -fstack-usage of gcc did not give any useful information, there has to be some recusing happening somewhere), but I'd prefer to use the espressif-provided version of tremor.

houhaiyan
Posts: 4
Joined: Thu May 30, 2019 2:08 am

Re: Using libesp-tremor directtly fails on av_open_callbacks

Postby houhaiyan » Thu May 30, 2019 2:35 am

Hi , I have not come across anything like this. Before solving the problem, i need to confirm the following things.
1. Did something go wrong with ESP-ADF demo?
2. Does the music you used work on other players?
if the answers are YES, could you give me the log and your used music for helping to reproduction? Thank you.

philippe_44
Posts: 8
Joined: Thu May 23, 2019 3:05 pm

Re: Using libesp-tremor directtly fails on av_open_callbacks

Postby philippe_44 » Sat Jun 01, 2019 4:13 am

houhaiyan wrote:
Thu May 30, 2019 2:35 am
Hi , I have not come across anything like this. Before solving the problem, i need to confirm the following things.
1. Did something go wrong with ESP-ADF demo?
2. Does the music you used work on other players?
if the answers are YES, could you give me the log and your used music for helping to reproduction? Thank you.
Hi - Thanks for answering
1.No
2.Absolutely. And my exact same source code works with my own tremor-compiled library.
BTW, I could not find a call to av_open_callbacks by scanning through *.c and *.h of the esp-adf. Do you use it?

houhaiyan
Posts: 4
Joined: Thu May 30, 2019 2:08 am

Re: Using libesp-tremor directtly fails on av_open_callbacks

Postby houhaiyan » Mon Jun 03, 2019 1:51 am

I see.
The function `av_open_callbacks` is used in decoding.
what can i do for you?

philippe_44
Posts: 8
Joined: Thu May 23, 2019 3:05 pm

Re: Using libesp-tremor directtly fails on av_open_callbacks

Postby philippe_44 » Mon Jun 03, 2019 2:48 am

houhaiyan wrote:
Mon Jun 03, 2019 1:51 am
I see.
The function `av_open_callbacks` is used in decoding.
what can i do for you?
We can probably leave it there. I wanted to leverage your libs rather than building mine, as I thought you have probably made a better optimization job than I did, but it's not the end of the world. There is probably something different in the header files you've compiled libtremor against, which explains that there is a mis-parameter passing when I'm calling them.

Who is online

Users browsing this forum: No registered users and 1 guest