SIP required authentication

Patsjemoe
Posts: 27
Joined: Wed Jul 17, 2019 11:22 am

SIP required authentication

Postby Patsjemoe » Sun Dec 15, 2019 8:52 am

Hi,
Making a new attempt on VOIP with ESP32 audio board and Asterisk.
I get a 401 unauthorized, but as far as I understand, this is created by the pbx , and on this, the ESP32 should send a response with the right credentials. (realm, nonce...)
Then I get following :
I (310803) SIP: Required authentication
E (310813) SIP: Error register device
So I assume now that the ESP32 is not answering to the 401 request....???
How can I check if the ESP32 has answered ?
regards
Ludo

Patsjemoe
Posts: 27
Joined: Wed Jul 17, 2019 11:22 am

Re: SIP required authentication

Postby Patsjemoe » Mon Dec 16, 2019 10:25 am

Hi,
In the mean time, I get authentication when using the latest esp-adf-v2.0-beta1
But now I get a strange OK-error.
SIP: Error register device Success
How do you explain the the error is a succes ? Should this be SIP: register device success ?

regards
Ludo

Patsjemoe
Posts: 27
Joined: Wed Jul 17, 2019 11:22 am

Re: SIP required authentication

Postby Patsjemoe » Tue Dec 17, 2019 1:39 pm

Hi,
Is anyone looking at this ?
I further looked into this, and have the feeling the code is not working.
I can see in Asterisk that I am registered, but am unreacheable,
Also, in the ESP32 SW, there is a "SIP_EVENT_REGISTERED" that should be visible on the screen when
the ESP is registered ....but this is not shown, so it seems not to get to this part in the SW...??
regards
Ludo

Who is online

Users browsing this forum: No registered users and 4 guests