AT commands for BLE throws error

asmaalekar
Posts: 12
Joined: Mon Mar 04, 2019 12:17 am

AT commands for BLE throws error

Postby asmaalekar » Mon Mar 04, 2019 3:25 am

hello everyone,

I am newbie to esp32. My company is planning to use esp32 in their product. We are trying to communicate to esp32 through UART to iMX6 to use BLE Services.

I want to use BLE services for which I was trying to initialize BLE. I send few commands and for AT+BLEINIT=2 it is throwing error.
Error is ERR CODE:0x01090000

I checked my firmware version through AT+GMR, which outputted data
AT+GMR
AT version:0.10.0.0(Jun 12 2017 05:47:13)
SDK version:v2.0-3-gbef9896
compile time:Aug 31 2017 05:59:53
Bin version:0.10.0


Could someone help me please, what could be possibly wrong?

Thanks,
Asma

Helen L
Posts: 38
Joined: Thu Aug 16, 2018 9:07 am

Re: AT commands for BLE throws error

Postby Helen L » Mon Mar 04, 2019 3:51 am

Maybe the AT version is too old to have the BLE functions. You can have a try with the latest AT firmware v1.1.3. https://www.espressif.com/en/support/do ... d%5B%5D=13

asmaalekar
Posts: 12
Joined: Mon Mar 04, 2019 12:17 am

Re: AT commands for BLE throws error

Postby asmaalekar » Tue Mar 05, 2019 1:00 am

Thank you Helen L.

I am trying to flash binaries from the link through ESP32 Download TooL, As ESP32-WROOM-32_AT_V1.1.2 has 11 binaries and I want to use them all, there are NOT enough rows to select each bin. So, I am trying to combine them.

when I hit the combine button selecting two binaries it opens the combine folder and I dont understand what shall i do next. It is not creating any bin in that folder just opens it.

Is there any documentation on how to combine binaries?
And what is the use of DeviceMasterKey folder path?

Helen L
Posts: 38
Joined: Thu Aug 16, 2018 9:07 am

Re: AT commands for BLE throws error

Postby Helen L » Tue Mar 05, 2019 3:34 am

In the ESP32_AT/factory is the combined bins for different ESP32 module. You can download one of them according to your actual module.

asmaalekar
Posts: 12
Joined: Mon Mar 04, 2019 12:17 am

Re: AT commands for BLE throws error

Postby asmaalekar » Wed Mar 06, 2019 1:50 am

Didnt get you. can you please elaborate, I want to use both BLE and wifi service. I want them all.

Helen L
Posts: 38
Joined: Thu Aug 16, 2018 9:07 am

Re: AT commands for BLE throws error

Postby Helen L » Mon Mar 11, 2019 6:04 am

There are two ways to upgrade the AT firmware:
1. FOTA: Connect the ESP32 to a router to access the internet, call command "AT+CIUPDATE" for upgrading.
2. Flashing the board: Download one of the bins in the ESP32_AT/factory directory to address 0x0.

Who is online

Users browsing this forum: No registered users and 2 guests