How to enable bt classic in esp32 wroom

asmaalekar
Posts: 12
Joined: Mon Mar 04, 2019 12:17 am

How to enable bt classic in esp32 wroom

Postby asmaalekar » Thu Mar 07, 2019 3:20 am

Hello Everyone,

I am using AT commands to connect with esp32. I am able to use ble and wiifi commands but when i use bt classic commands it is giving error.

I used example commands from https://github.com/espressif/esp32-at/b ... uetooth.md
for BT classic
its giving error.

Do I need to enable BT classic seperately. if yes how and from where?
Is there any documentation to how to enabled BT Classic?
and also AT commands doc for BT classic?

More info:
i am using the latest AT firmware version from ESP- ESP32-WROOM-32 AT Bin V1.1.2

Thanks,
Asma

shalinipatil@123
Posts: 2
Joined: Thu Jun 20, 2019 5:19 am

Re: How to enable bt classic in esp32 wroom

Postby shalinipatil@123 » Thu Jun 20, 2019 5:49 am

Hello
I am using ESP WROOM-32 But i am not getting AT command response can you please tell me steps from hardware connection to BLE comunication.

Helen L
Posts: 38
Joined: Thu Aug 16, 2018 9:07 am

Re: How to enable bt classic in esp32 wroom

Postby Helen L » Thu Jun 20, 2019 6:05 am

The default AT bin does not support BT classic, you need to clone the esp-at project and configure it according to the doc https://github.com/espressif/esp32-at/b ... uetooth.md, and then compile to get a new AT bin which supports BT classic.
ESP32 AT doc https://github.com/espressif/esp32-at/b ... nds_Set.md

Who is online

Users browsing this forum: No registered users and 1 guest