VSCode idf插件升级到0.6.0的问题

zlflove99
Posts: 1
Joined: Mon Jan 11, 2021 1:41 pm

VSCode idf插件升级到0.6.0的问题

Postby zlflove99 » Mon Jan 11, 2021 2:01 pm

VSCode IDF插件升级到0.6.0后Monitor无法串口打印,退回到0.5.1后可正常打印,第一次点击出现如下的提示:
  1. Windows PowerShell
  2. 版权所有 (C) Microsoft Corporation。保留所有权利。
  3.  
  4. 尝试新的跨平台 PowerShell https://aka.ms/pscore6
  5.  
  6. PS D:\SelfSoftware\ESP32\UserProject\wear_levelling> $Env:Path = "
  7. >> $Env:IDF_PATH = "
  8. PS D:\SelfSoftware\ESP32\UserProject\wear_levelling> $Env:IDF_TARGET = "
  9. >> $Env:PYTHON = "
  10. PS D:\SelfSoftware\ESP32\UserProject\wear_levelling> $Env:IDF_PYTHON_ENV_PATH = "
  11. >> cls
  12. >> d:\SelfSoftware\ESP32\ESP_IDFTools\python_env\idf4.3_py3.9_env\Scripts\python.exe d:\SelfSoftware\ESP32\IDF_Master\esp-idf\tools\idf.py -p COM3 monitor
  13. >>
第二次点击出现如下的提示:
  1. 版权所有 (C) Microsoft Corporation。保留所有权利。
  2. 尝试新的跨平台 PowerShell https://aka.ms/pscore6
  3. PS D:\SelfSoftware\ESP32\UserProject\wear_levelling> d:\SelfSoftware\ESP32\ESP_IDFTools\python_env\idf4.3_py3.9_env\Scripts\python.exe d:\SelfSoftware\ESP32\IDF_Master\esp-idf\tools\idf.py -p COM3 monitor
  4. Traceback (most recent call last):
  5.   File "d:\SelfSoftware\ESP32\IDF_Master\esp-idf\tools\idf.py", line 805, in <module>
  6.     main()
  7.   File "d:\SelfSoftware\ESP32\IDF_Master\esp-idf\tools\idf.py", line 720, in main
  8.     checks_output = check_environment()
  9.   File "d:\SelfSoftware\ESP32\IDF_Master\esp-idf\tools\idf.py", line 77, in check_environment
  10.     debug_print_idf_version()
  11.   File "d:\SelfSoftware\ESP32\IDF_Master\esp-idf\tools\idf.py", line 126, in debug_print_idf_version    
  12.     version = idf_version()
  13.   File "d:\SelfSoftware\ESP32\IDF_Master\esp-idf\tools\idf_py_actions\tools.py", line 54, in idf_version
  14.     version = subprocess.check_output([
  15.   File "C:\Users\ZLF\AppData\Local\Programs\Python\Python39\lib\subprocess.py", line 420, in check_output
  16.     return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
  17.   File "C:\Users\ZLF\AppData\Local\Programs\Python\Python39\lib\subprocess.py", line 501, in run
  18.     with Popen(*popenargs, **kwargs) as process:
  19.   File "C:\Users\ZLF\AppData\Local\Programs\Python\Python39\lib\subprocess.py", line 947, in __init__
  20.     self._execute_child(args, executable, preexec_fn, close_fds,
  21.   File "C:\Users\ZLF\AppData\Local\Programs\Python\Python39\lib\subprocess.py", line 1416, in _execute_child
  22.     hp, ht, pid, tid = _winapi.CreateProcess(executable, args,
  23. FileNotFoundError: [WinError 2] 系统找不到指定的文件。
  24. PS D:\SelfSoftware\ESP32\UserProject\wear_levelling>

XLstone
Posts: 2
Joined: Sun Jan 17, 2021 5:04 am

Re: VSCode idf插件升级到0.6.0的问题

Postby XLstone » Sun Jan 17, 2021 5:06 am

我也是一样的问题,老哥你解决了吗?

Who is online

Users browsing this forum: No registered users and 4 guests