使用eclipse IDE 安装工具链出错

liukaihua
Posts: 1
Joined: Thu Apr 08, 2021 6:53 am

使用eclipse IDE 安装工具链出错

Postby liukaihua » Thu Apr 08, 2021 6:56 am

你好,我在安装eclipse 插件时,出错,麻烦帮忙看下原因:

Installing tools...
This can take a while. Please be patient.
Executing C:\Users\a\AppData\Local\Programs\Python\Python37\python.exe C:\Users\a\Desktop\esp-idf\tools\idf_tools.py install all
Installing tools: xtensa-esp32-elf, xtensa-esp32s2-elf, esp32ulp-elf, esp32s2ulp-elf, cmake, openocd-esp32, ninja, idf-exe, ccache, dfu-util
Skipping xtensa-esp32-elf@esp-2020r3-8.4.0 (already installed)
Skipping xtensa-esp32s2-elf@esp-2020r3-8.4.0 (already installed)
Skipping esp32ulp-elf@2.28.51-esp-20191205 (already installed)
Skipping esp32s2ulp-elf@2.28.51-esp-20191205 (already installed)
Skipping cmake@3.16.4 (already installed)
Skipping openocd-esp32@v0.10.0-esp32-20200709 (already installed)
Skipping ninja@1.10.0 (already installed)
Skipping idf-exe@1.0.1 (already installed)
Skipping ccache@3.7 (already installed)
Skipping dfu-util@0.9 (already installed)

Executing C:\Users\a\AppData\Local\Programs\Python\Python37\python.exe C:\Users\a\Desktop\esp-idf\tools\idf_tools.py install-python-env
Processing c:\users\a\desktop\esp-idf\tools\kconfig_new\esp-windows-curses
Requirement already satisfied: setuptools>=21 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 4)) (54.1.2)
Requirement already satisfied: click>=5.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 8)) (7.1.2)
Requirement already satisfied: pyserial>=3.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 9)) (3.5)
Requirement already satisfied: future>=0.15.2 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 10)) (0.18.2)
Requirement already satisfied: cryptography>=2.1.4 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 11)) (3.4.7)
Requirement already satisfied: pyparsing<2.4.0,>=2.0.3 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 12)) (2.3.1)
Requirement already satisfied: pyelftools>=0.22 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 13)) (0.27)
Requirement already satisfied: gdbgui==0.13.2.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (0.13.2.0)
Requirement already satisfied: pygdbmi<=0.9.0.2 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 17)) (0.9.0.2)
Requirement already satisfied: reedsolo<=1.5.4,>=1.5.3 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 21)) (1.5.4)
Requirement already satisfied: bitstring>=3.1.6 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 22)) (3.1.7)
Requirement already satisfied: ecdsa>=0.16.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from -r C:\Users\a\Desktop\esp-idf\requirements.txt (line 23)) (0.16.1)
Requirement already satisfied: windows-curses in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from esp-windows-curses==0.1->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 29)) (2.2.0)
Requirement already satisfied: gevent<2.0,>=1.2.2 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (1.5.0)
Requirement already satisfied: Pygments<3.0,>=2.2.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (2.8.1)
Requirement already satisfied: Flask<1.0,>=0.12.2 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (0.12.5)
Requirement already satisfied: Flask-SocketIO<3.0,>=2.9 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (2.9.6)
Requirement already satisfied: Flask-Compress<2.0,>=1.4.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (1.9.0)
Requirement already satisfied: cffi>=1.12 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from cryptography>=2.1.4->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 11)) (1.14.5)
Requirement already satisfied: six>=1.9.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from ecdsa>=0.16.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 23)) (1.15.0)
Requirement already satisfied: pycparser in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from cffi>=1.12->cryptography>=2.1.4->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 11)) (2.20)
Requirement already satisfied: Jinja2>=2.4 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from Flask<1.0,>=0.12.2->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (2.11.3)
Requirement already satisfied: Werkzeug<1.0,>=0.7 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from Flask<1.0,>=0.12.2->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (0.16.1)
Requirement already satisfied: itsdangerous>=0.21 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from Flask<1.0,>=0.12.2->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (1.1.0)
Requirement already satisfied: brotli in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from Flask-Compress<2.0,>=1.4.0->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (1.0.9)
Requirement already satisfied: python-socketio>=1.6.1 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from Flask-SocketIO<3.0,>=2.9->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (5.1.0)
Requirement already satisfied: greenlet>=0.4.14 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from gevent<2.0,>=1.2.2->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (1.0.0)
Requirement already satisfied: MarkupSafe>=0.23 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from Jinja2>=2.4->Flask<1.0,>=0.12.2->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (1.1.1)
Requirement already satisfied: python-engineio>=4 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from python-socketio>=1.6.1->Flask-SocketIO<3.0,>=2.9->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (4.0.1)
Requirement already satisfied: bidict>=0.21.0 in c:\users\a\.espressif\python_env\idf4.2_py3.7_env\lib\site-packages (from python-socketio>=1.6.1->Flask-SocketIO<3.0,>=2.9->gdbgui==0.13.2.0->-r C:\Users\a\Desktop\esp-idf\requirements.txt (line 14)) (0.21.2)
Building wheels for collected packages: esp-windows-curses
Building wheel for esp-windows-curses (setup.py): started
Building wheel for esp-windows-curses (setup.py): finished with status 'done'
Created wheel for esp-windows-curses: filename=esp_windows_curses-0.1-py3-none-any.whl size=1170 sha256=a2cd55ba272a1d97bda7a4d5e92485669b081ee9aefb70b57af291f130eff971
Stored in directory: c:\users\a\appdata\local\pip\cache\wheels\c7\ac\13\6bafbcfde7d3238e9c4690a9672e0902d944334bacd4d3c7bd
Successfully built esp-windows-curses
Installing collected packages: esp-windows-curses
Attempting uninstall: esp-windows-curses
Found existing installation: esp-windows-curses 0.1
Uninstalling esp-windows-curses-0.1:
Successfully uninstalled esp-windows-curses-0.1
Successfully installed esp-windows-curses-0.1
Installing Python packages from C:\Users\a\Desktop\esp-idf\requirements.txt

Executing C:\Users\a\AppData\Local\Programs\Python\Python37\python.exe C:\Users\a\Desktop\esp-idf\tools\idf_tools.py export --format=key-value
Traceback (most recent call last):
File "C:\Users\a\Desktop\esp-idf\tools\idf_tools.py", line 1492, in <module>
main(sys.argv[1:])
File "C:\Users\a\Desktop\esp-idf\tools\idf_tools.py", line 1488, in main
action_func(args)
File "C:\Users\a\Desktop\esp-idf\tools\idf_tools.py", line 1022, in action_export
idf_python_env_path, idf_python_export_path, virtualenv_python = get_python_env_path()
File "C:\Users\a\Desktop\esp-idf\tools\idf_tools.py", line 861, in get_python_env_path
cwd=global_idf_path, env=os.environ).decode()
File "C:\Users\a\AppData\Local\Programs\Python\Python37\lib\subprocess.py", line 411, in check_output
**kwargs).stdout
File "C:\Users\a\AppData\Local\Programs\Python\Python37\lib\subprocess.py", line 488, in run
with Popen(*popenargs, **kwargs) as process:
File "C:\Users\a\AppData\Local\Programs\Python\Python37\lib\subprocess.py", line 800, in __init__
restore_signals, start_new_session)
File "C:\Users\a\AppData\Local\Programs\Python\Python37\lib\subprocess.py", line 1207, in _execute_child
startupinfo)
FileNotFoundError: [WinError 2] ϵͳ�Ҳ���ָ�����ļ���
Configured CDT Build Environment variables. You can check Preferences > C/C++ > Build > Environment
Configured CMake toolchain. You can check Preferences > C/C++ > CMake
Install tools completed.

zliudr
Posts: 266
Joined: Thu Oct 03, 2019 5:15 am

Re: 使用eclipse IDE 安装工具链出错

Postby zliudr » Thu Apr 08, 2021 10:43 pm

也许不识中文?
FileNotFoundError: [WinError 2] ϵͳ�Ҳ���ָ�����ļ���

Who is online

Users browsing this forum: No registered users and 7 guests