Problems building example

johncblacker
Posts: 6
Joined: Mon Mar 18, 2019 11:47 pm

Problems building example

Postby johncblacker » Tue May 04, 2021 3:32 pm

I'm trying to follow the instructions in the ESP-EYE Getting Started Guide but am running into a problem. I'm performing on a windows 10 system and have cloned the esp-who repository and have set my IDF_PATH thusly:
/v/Git-projects/esp-who/esp-idf
But, when I try to issue: make defconfig I'm getting the following error output:
V:\Git-projects\esp-who\examples\single_chip\face_recognition_solution>make defconfig
makefile:10: V:/Git-projects/esp-who/examples/single_chip/face_recognition_solution/V:\Git-projects\esp-who\examples\single_chip\face_recognition_solution/../../../components/component_conf.mk: Invalid argument
makefile:11: /v/Git-projects/esp-who/esp-idf/make/project.mk: No such file or directory
make: *** No rule to make target `/v/Git-projects/esp-who/esp-idf/make/project.mk'. Stop.
So, I don't know what I've done wrong and how to fix problem so I can build the face_recognition_solution example.

My make is:
GNU Make 3.81
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

This program built for i386-pc-mingw32

Perhaps something wrong there?
Thank you for help.

johncblacker
Posts: 6
Joined: Mon Mar 18, 2019 11:47 pm

Re: Problems building example - SOLVED!

Postby johncblacker » Wed May 05, 2021 3:18 pm

I was using a getting started document that had either old or incorrect information in it as it turned out. I found a good document which led me to the solution:
instead of: make menuconfig

issue: idf.py menuconfig

That worked for me. I did have to do some preliminary setup using: install.bat and export.bat from within the esp-idf directory in order for the esp-idf framework to be properly recognized on my windows 10 system, but I figured that out too and the getting started doc did mention proper setup of the esp-idf beforehand.

So, problem solved, my bad. ISSUE CLOSED.

Who is online

Users browsing this forum: No registered users and 2 guests