Page 1 of 1

ESP-IDF Version for ESP-WHO samples

Posted: Thu Mar 14, 2019 9:39 am
by Jean-Luc
So I've started to play with ESP-EYE board and ESP-WHO framework.
I first installed ESP-IDF 3.1.3, but the detection_with_command_line sample would just return camera errors, and recognition_solution would fail to build due to esp_http_server missing.

So I've now removed ESP-IDF 3.1.3, and install ESP-IDF 3.3-beta2 instead. recognition_solution builds fine, it can detect hilexin word, and create an access point to which I can connect with my Ubuntu 18.04 computer. But now when I try to access in Firefox it will just load forever ("waiting for"), and show a white screen.

I guess it may be an issue with the IDF version I'm using. Thanks in advance.

Re: ESP-IDF Version for ESP-WHO samples

Posted: Fri Mar 22, 2019 4:16 pm
by joba-1
Hi Jean-Luc,

looks like I have a similar problem. Maybe it helps knowing this is not a one time error.

I tried to compile the webserver example like this (changing serial port, adding wlan config and selecting AI-Thinker board in menuconfig):

Code: Select all

git  clone --recursive 
cd esp-who/examples/single_chip/camera_web_server
make defconfig
make menuconfig
make clean
make -j6 flash
and I get this error:

Code: Select all

CC build/main/app_httpd.o
/home/joachim/esp-who/examples/single_chip/camera_web_server/main/app_httpd.c:15:29: fatal error: esp_http_server.h: No such file or directory
compilation terminated.
There was a commit changing the esp-idf version for esp-who very recently, so I guess this is the problem, but I dont know how to revert it (not used to git submodules).

I hope someone can help out here to fix that.

Re: ESP-IDF Version for ESP-WHO samples

Posted: Fri Mar 22, 2019 5:30 pm
by joba-1
I read a bit about git submodules and tested a bit further:

I changed to esp-idf directory/submodule and did a git log to find all commits mentioning http_server.
I checked out commits preceeding those http_server commits one by one and rebuilt:

Code: Select all

cd esp-idf
git checkout <hash>
cd <example-dir>
make clean
make all
This did not help, same error. So I repeated this after changing the include from esp_http_server.h to http_server.h since I read the filename has changed at some point. Still no joy. I give up on this.

Btw. the CameraWebServer example in Arduino IDE compiles just fine, but the web page it serves is dead slow, like over a minute for the initial load and stills or streams only work sometimes, but mostly not :(
Well, at least I know now the hardware could work in principle and is not entirely useless.

Re: ESP-IDF Version for ESP-WHO samples

Posted: Wed Mar 27, 2019 8:08 pm
by joba-1
The slowness of the arduino sample is gone if I do not use WLAN repeaters.
Seems espressifs wifi stack does not like having several stations with the same SSID around?
Had similar issues I could not narrow down until now with esp8266 too.

Pulled esp-who, that had some minor updates, but still no working webcamserver example for me.

Re: ESP-IDF Version for ESP-WHO samples

Posted: Tue Apr 02, 2019 3:24 pm
by patrice
I had the same problem and finally I found the solution.
I fixed the problem with the version 3.3. With this version you need to redefine your IDF_PATH with something like this : export IDF_PATH=~/esp32/esp-who/esp-idf

I found a part of the solution later here :
it is in chinese language, but command line are clear !!

Re: ESP-IDF Version for ESP-WHO samples

Posted: Wed Apr 03, 2019 2:58 am
Hi all,
Sorry for the late reply.
For the problem of compiling issue about 'httpd', the IDF should be synchronized with the submodule in the esp-who repo. Since the http server function interface has been changed from IDFv3.1, you have to update from that version. You can do `git submodule` to get the commit-id of esp-idf which is suitable for esp-who. Then go to your $IDF_PATH, do `git fetch` and chechout the commit-id which is copied from the esp-who submodule.