eth2wifi sample code

hahmadi
Posts: 2
Joined: Wed Apr 24, 2019 3:13 pm

eth2wifi sample code

Postby hahmadi » Wed Apr 24, 2019 3:42 pm

Hello,

I am trying to test the following sample on ESP32 Gateway Rev C from Olimex.

https://github.com/espressif/esp-iot-so ... s/eth2wifi

I am using IDF stable version 3.2. I successfully compiled and ran the sample in Station Mode. Here is the list items that works and the ones that are not working.

Working:
A pc connected to ethernet port of evaluation board acquires IP address successfully and a gateway is assigned.
Arp -a on the pc connected to evaluation board shows a list nodes and Mac addresses correctly
on the router the connected computer is listed and mac address is correct.

Not working:
Ping to the IP address assigned to connected pc fails.
Ping from the connected pc to any node with the local network fails.
Ping from the connected pc to gateway also fails.

questions:
Is this a viable sample code, can anyone confirm that this sample is working at all. If the answer is yes please specify the IDF version that is working with this sample.

any other comment on why the sample is not working will be very much appreciated.

hahmadi
Posts: 2
Joined: Wed Apr 24, 2019 3:13 pm

Re: eth2wifi sample code

Postby hahmadi » Sat Apr 27, 2019 9:07 pm

I tested this sample with IDF version 3.1.4 and it works as it should. I still can not say why it is NOT working with version 3.2. I believe it is worth finding out what it is in version 3.2 that causes this problem.

ESP_morris
Posts: 41
Joined: Wed Sep 05, 2018 6:23 am

Re: eth2wifi sample code

Postby ESP_morris » Tue May 07, 2019 2:13 am

hahmadi wrote:
Sat Apr 27, 2019 9:07 pm
I tested this sample with IDF version 3.1.4 and it works as it should. I still can not say why it is NOT working with version 3.2. I believe it is worth finding out what it is in version 3.2 that causes this problem.
Sorry for the delay reply and thanks a lot for reporting this issue. We will figure it out ASAP.

In idf/v3.1, we enable the promiscuous mode by default. While in idf/v3.2 and later, we have disabled it by default. After re-enable it by add this line https://github.com/espressif/esp-idf/bl ... dev.c#L115, the eth2wifi should work.

Who is online

Users browsing this forum: MSN [Bot] and 14 guests