Trouble uploading software to ESP32-WROOM-32

lalleglad
Posts: 7
Joined: Tue Feb 25, 2020 1:12 pm

Trouble uploading software to ESP32-WROOM-32

Postby lalleglad » Thu Mar 26, 2020 2:00 pm

I have trouble uploading software, for now just the 'hello_world' taken from the esp-idf examples, to an ESP32-WROOM-32 board connected my Win10 PC through ESP-Prog using either the JTAG or UART port.

I would like to know if anyone has any ideas or pointers to what may be missing?

I had no problems with a ESP32-DevKitC V4 development board, both uploading and running the hello_world example and my own code.

I put comparable outputs in attached files, from my screen showing both working and partly working examples.

It seems I can inquire the ESP32-WROOM-32 for some information, but I am not able to upload any binary data file.
Also, I wonder when asking about the flash_id, if the following returned data is valid?

Manufacturer: ff
Device: ffff

The ESP32-DevKitC V4 returns the following:

Manufacturer: 20
Device: 4016
Attachments
20200326_143223.jpg
ESP32-WROOM-32 with ESP-Prog setup
20200326_143223.jpg (2.64 MiB) Viewed 311 times
ESP32-DevKitC_V4_working_20200326.txt
Screen output showing a working example
(3.19 KiB) Downloaded 14 times
ESP32-WROOM-32_ESP-Prog_partially-working_20200326.txt
Screen output showing an only partially working example
(3.26 KiB) Downloaded 14 times

ESP_Sprite
Posts: 3262
Joined: Thu Nov 26, 2015 4:08 am

Re: Trouble uploading software to ESP32-WROOM-32

Postby ESP_Sprite » Thu Mar 26, 2020 10:04 pm

I see you have red wires connecting pads on the bottom of the module to pads on the side. What are those for? The pads on the bottom are mostly for flash; I think the fact that you have those tied to something else is the cause of your issues.

lalleglad
Posts: 7
Joined: Tue Feb 25, 2020 1:12 pm

Re: Trouble uploading software to ESP32-WROOM-32

Postby lalleglad » Fri Mar 27, 2020 9:25 am

Thank you for your reply.

The red wires are fixes to originally operate an RGB LED with PWM on GPIO9, GPIO10 and GPIO11.
I changed that to GPIO2, GPIO4 and GPIO5, but the connections to 9, 10 and 11 weren't cut (yet).
Will that affect the upload of software?

Please see the attached diagram.

When attempting upload I have tried holding down the Boot button on the ESP-Prog board, and I can see the GPIO0 goes low, but the result is the same.
Attachments
image001.jpg
image001.jpg (31.07 KiB) Viewed 221 times

ESP_Sprite
Posts: 3262
Joined: Thu Nov 26, 2015 4:08 am

Re: Trouble uploading software to ESP32-WROOM-32

Postby ESP_Sprite » Fri Mar 27, 2020 2:26 pm

Yes. GPIO9, 10 and 11 are internally connected to the flash; you should leave those pins entirely unconnected and your problem will go away.

lalleglad
Posts: 7
Joined: Tue Feb 25, 2020 1:12 pm

Re: Trouble uploading software to ESP32-WROOM-32

Postby lalleglad » Sat Mar 28, 2020 11:55 am

Thank you for the info.

I disconnected them and as you said, I can now upload SW to the WROOM.

So, it means that these pins are effectively not generally available GPIOs?
If that is the case, it would be great if the documentation reflects that.

Then, I can upload SW to the WROOM through the UART interface, but not using the JTAG interface, which I also hope to use for debugging.
Do you have any hints or pointers regarding the JTAG?

ESP_Sprite
Posts: 3262
Joined: Thu Nov 26, 2015 4:08 am

Re: Trouble uploading software to ESP32-WROOM-32

Postby ESP_Sprite » Sat Mar 28, 2020 12:59 pm

You should nowadays also be able to change the firmware using jtag. For more info, you can start here.

Who is online

Users browsing this forum: No registered users and 43 guests