[SOLVED] Can't program ESP32 over UART on own PCB

timm_f
Posts: 9
Joined: Tue Feb 20, 2018 2:53 pm

[SOLVED] Can't program ESP32 over UART on own PCB

Postby timm_f » Mon Apr 16, 2018 9:18 am

Hello everybody,

currently I am working on a self developed PCB with a WROOM-ESP32 on board. The PCB is a new design, got it delivered today. The ESP32 is unprogrammed.
I did develop the firmware on a devboard.
I can't programm the ESP32, neither with "esptool" nor in the build environment ("make flash").
The result is always:
Connecting........_____....._____....._____....._____....._____....._____....._____....._____....._____....._____
A fatal error occurred: Failed to connect to Espressif device: Invalid head of packet ('\x00')

Things I did:
[*] connected the ESP32-UART (wroom pin 34/34=rxd/txd) to a serial-USB-converter connected to my PC.
[*] verified correct COM port in device manager (COM14)
[*] set up build environment to correct COM port (export ESPPORT=COM14)
[*] I did look at the signals using an oscilloscope - there is data TX'd to the ESP32
[*] I testwise exchanged TX and RX - same result

How can I process further and narrow down this problem?
Thanks in advance for any input.

Best Regards, Timm
Last edited by timm_f on Thu Apr 19, 2018 6:37 am, edited 1 time in total.


timm_f
Posts: 9
Joined: Tue Feb 20, 2018 2:53 pm

Re: Can't program ESP32 over UART on own PCB

Postby timm_f » Mon Apr 16, 2018 2:08 pm

Hello,

thank you for your response.
I verified that GPIO0 and GPIO2 are low at power up of module.
Then, I release GPIO0 and afterwards start the program process.
Still, I can't program the device.
Serial data is being sent towards the ESP32 and I can measure it at pin 34/rxd. Level is ok, 3,3V.
The ESP32 doesn't answer on the txd pin.

Any other ideas?
Thanks in advance.

User avatar
fly135
Posts: 213
Joined: Wed Jan 03, 2018 8:33 pm
Location: Orlando, FL

Re: Can't program ESP32 over UART on own PCB

Postby fly135 » Mon Apr 16, 2018 3:27 pm

I'm surprised that you would develop your own board without even having the experience of using a $10 devkit board. You should be seeing a message on the terminal saying that it's ready for download. The BOOT pin GPIO 0 should be low, then the EN (CHIP_PU) pin should be used to reset. At that point you should see a "Waiting for download" message.

At least that's my understanding. If I'm wrong someone will be along shortly to set me straight.

John A

WiFive
Posts: 1818
Joined: Tue Dec 01, 2015 7:35 am

Re: Can't program ESP32 over UART on own PCB

Postby WiFive » Mon Apr 16, 2018 8:28 pm

Are you sure you have correct program port pins

https://c1.staticflickr.com/5/4721/4010 ... 65f2_b.jpg

User avatar
hassan789
Posts: 108
Joined: Thu Jun 29, 2017 2:15 am

Re: Can't program ESP32 over UART on own PCB

Postby hassan789 » Tue Apr 17, 2018 5:54 pm

JTAG lines can be sensitive. Can you post a oscilloscope screenshot of the lines?

timm_f
Posts: 9
Joined: Tue Feb 20, 2018 2:53 pm

Re: Can't program ESP32 over UART on own PCB

Postby timm_f » Wed Apr 18, 2018 7:32 am

Hello,

thanks very much for the help to everybody who contributed!
The problem was a hardware issue with the power supply on our PCB.
Now, I can program the board.
P.S. can I mark the thread as solved in any way?

Best Regards, Timm

User avatar
hassan789
Posts: 108
Joined: Thu Jun 29, 2017 2:15 am

Re: Can't program ESP32 over UART on own PCB

Postby hassan789 » Wed Apr 18, 2018 6:58 pm

timm_f wrote:Hello,

thanks very much for the help to everybody who contributed!
The problem was a hardware issue with the power supply on our PCB.
Now, I can program the board.
P.S. can I mark the thread as solved in any way?

Best Regards, Timm


you can edit the title and add a [SOLVED] tag

Who is online

Users browsing this forum: Google [Bot] and 2 guests