Problem with compiling

Posts: 10
Joined: Thu May 24, 2018 7:03 pm

Problem with compiling

Postby mosheb » Sat Sep 15, 2018 8:33 am

I have this problem:

When I compile, I get the following error.
Arduino: 1.8.7 (Windows 10), Board: "NodeMCU-32S, 80MHz, 921600"
Build options changed, rebuilding all
fork/exec C:\Users\#####\AppData\Local\Arduino15\packages\esp32\tools\esptool\2.3.1/esptool.exe: The requested operation requires elevation.
Error compiling for board NodeMCU-32S.
This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
I understand the problem is in the file esptool.exe
But I do not understand what the sentence says " The requested operation requires elevation."

I run Windows troubleshooting on the file, and then the compilation goes through, and I manage to burn.
The problem is that I can not save the patches that Windows performs.
I have two types of boards, and both have the same problem.
1. ESP32 ESP-32S NodeMCU Development Board
2. WEMOS Lolin32 CP2104

I checked the USB cable, and changed the USB inputs.
I have tried to uninstall and reinstall everything related to ESP32.
The installation I do is recommended by Santos certified on this site. ... tructions/

I replaced the IDE version, from 1.85 to 1.87.

And I still have not reached a solution.
Can anyone help?
Thanks in advance.

Posts: 10
Joined: Thu May 24, 2018 7:03 pm

Re: Problem with compiling

Postby mosheb » Mon Sep 17, 2018 7:43 am

So for none of the 42 views, there is no suggestion how to solve the problem?

Posts: 2
Joined: Mon Sep 10, 2018 2:08 pm

Re: Problem with compiling

Postby cicciocb » Mon Sep 17, 2018 9:26 am

The message "The requested operation requires elevation." means that esptools.exe requires the administrator rights.
Probably it has been configured to run as this.

In your case, you should try to run arduino using right click and selecting "run as administrator".

Posts: 10
Joined: Thu May 24, 2018 7:03 pm

Re: Problem with compiling

Postby mosheb » Mon Sep 17, 2018 12:29 pm

That's right, you're right, thank you very much for your help.
I updated IDE to version 187 and did not change the settings to work as an administrator.

But now I got stuck with another problem.
I do not know if it is possible to continue here, or to open a new post.
Could you help me with this problem as well?

When I burn the following code from the examples: see picture.

In the IDE terminal, I see an endless scroll of software. see picture.

The same problem exists with the second panel, I think there is still a problem with the settings,
And I do not know where, I will thank you very much, or anyone who can help me.

Thanks in advance.
17_09_2018-12_56_28_526.jpg (391.92 KiB) Viewed 573 times
17_09_2018-12_58_57_114.jpg (351.75 KiB) Viewed 573 times

Return to “ESP32 Arduino”

Who is online

Users browsing this forum: No registered users and 7 guests